thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

820-4924 boots to unknown screen

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-4924 boots to unknown screen

    I have this board that was liquid damaged. I marked these areas that had the liquid damage before cleaning and replacing components.

    d7050/c7050/c7060 area
    vias above kbd connector and other side
    r4856/r4857/r4858/r4810/c4810 ( These components were all replaced)
    isl6259 area c7150 (replaced C7116)
    U1900 and C1924 (C1924 was burned so I replaced it as well as U1900)

    The machine turns on when I plug in the charger and it takes about 5 seconds before it boots to the apple logo.
    It takes a few seconds and loads up to the page you can see in the pictures below. I see the trackpad cursor on the page but it won't move when I use the trackpad.
    When I try to turn the machine off with the power button it doesn't turn work. I have to unplug the charger and battery in order to shut it off.

    https://www.dropbox.com/sh/vryoho2y7...We4zjXJya?dl=0

  • #2
    Bad trackpad/cable/connector.

    Comment


    • #3
      I disconnected the trackpad cable and turned it on and the same thing happened. I also plugged in another tpad cable and still nothing changed.
      The trackpad connector looks perfectly clean on both sides of the board.

      I also plugged in a new keyboard and that one didn't work either. I tried plugging in a usb with mac osx and hold option key but nothing happened. I also couldn't turn the machine off with the new keyboard.

      Do you know what exactly those images mean? I can't find any information on it
      Last edited by ytesfay80; 11-24-2016, 02:20 AM.

      Comment


      • #4
        Okay so now I plugged in a new trackpad and cable together and this time when I booted it took me to the screen where it asks to choose the language for your computer so I think the trackpad may need replacing. When I do try to move my finger around on the trackpad the cursor does not move but I'm not sure if that is because the trackpad is not assembled into the machine.

        I also plugged in another keyboard and I still cannot turn the machine off with the power button or use the option key to boot.

        I checked voltages on the keyboard connector (J4813)
        Pins 1/2/3 - 0v
        Pin 4 - 3.42v
        Pin 5 - 0v
        Pin 6 - saw 1.3v and it goes down.

        On the other side of the board I checked for continuity from Pin 2 of R4810 to Probe #816 and there was no beep.
        There is continuity though from Pin 5 of J4813 to the via above it.

        Update: I ran a wire from Pin 2 of R4810 to Probe #816 and now the power button works to turn off the machine.
        I'm still not able to boot my usb stick with the option key pressed even though I see Pin 2 of J4813 jump to 3.4v when I press the left option key.
        Last edited by ytesfay80; 11-24-2016, 03:55 AM.

        Comment


        • #5
          Okay so I plugged in the original trackpad cable and now it is working fine.

          Comment

          thread bottom ad

          Collapse
          Working...
          X