thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

820-3437-B no power, no green light

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-3437-B no power, no green light

    No liquid damage.
    PPBUS_G3HOT is missing
    PP3V42_G3H is present
    SMC_RESET_L is present
    SMC_DCIN_ISENSE is missing

  • #2
    SMC_BC_ACOK present?

    Comment


    • #3
      Nope. It is missing.

      Comment


      • #4
        Possible dead ISL6259. Check R7051/52, R7005, R7021/22

        Comment


        • #5
          Changed ISL6259 from donor board. Green light returned. Fans spinned up for 2-3 seconds.
          Then after some attempts green light went away.
          PPBUS_G3H is present this time.
          Those resistors seem okay.

          Comment


          • #6
            Again, is ACOK present now? What is PPBUS voltage?

            Comment


            • #7
              ACOK is present.
              PPBUS is 8.57v

              Comment


              • #8
                Must have green light then. IO board and cable are tested ok?

                Comment


                • #9
                  Tested with 3 IO cables. Same.
                  Also I re-checked those resistors. R7005 was too high 300ohm instead of 20. Not sure why I missed that before. I changed it, now it is 20ohm as it should but nothing changed.
                  There is something weird that might be relevant information: when i plug the charger in another laptop and put it back the charger light returns. It remains even after a few attempts of connecting and disconnecting from IO board. It start the fan for 2-3 seconds then it stops.

                  I fixed that retina board 2 days ago that was behaving somewhat similar by reballing the SMC. Does it worth a try in this case??

                  Comment


                  • #10
                    Could be corrosion under SMC. If R7005 was dead then the ISL was also killed. This only happens with crap Chinese chargers like this. It may have killed the SMC also. Check for corrosion, but this may be a dead SMC.

                    Comment


                    • #11
                      So I did change the ISL again. Nothing changed. Changed the SMC too. Still no green light with quarter fan spin.
                      The current sensing seems messed but those resistors seem okay.
                      Just to be sure: R7151 is around 3.5ohm instead of 2ohm respectively R7152 is around 1ohm instead of 0ohm. Could this be the issue?

                      Comment


                      • #12
                        If PPBUS is 8.5V and ACOK is present the ISL will be fine. Is CPU Vcore coming high for a moment?

                        Comment


                        • #13
                          Yes during the quarter fan spin vcore jumps up to 1.8V.

                          Comment


                          • #14
                            Check corrosion around U6100 and the resistors in serie with the data lines.

                            Comment


                            • #15
                              No corrosion around. The two resistors in line (R6101,R6102) are fine.

                              Comment

                              thread bottom ad

                              Collapse
                              Working...
                              X