thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

[SOLVED]820-2936, BIL Button Doesn't Work (Board Issue)

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED]820-2936, BIL Button Doesn't Work (Board Issue)

    Known-good test case, known-good BIL assembly/cable, battery is detected by board, charges fine, and the BIL LEDs all light up appropriately when a charger is connected, but the actual button function does not work--it does not prompt the LEDs to light up to show the charge level indication, etc. There was liquid near the SMC, and this is the only issue (it's for a board to be sold as refurbished, so we want it 100% functional). All other functions work fine. I checked a few resistors related to SMC_BIL_BUTTON_L, but they all measure out fine. Connector itself looks fine.

    Is there anything else I can check before reflowing/pulling the SMC to check for gunk?

  • #2
    BIL_BUTTON should be pulled low when you press the button. R5081 pull up ok?

    Comment


    • #3
      Yeah, R5081 is good. I'll check that it's pulled low in just a minute. Another thing to note (strange behavior), is that immediately after a battery is connected to the board, the BIL LED#1 flashes (the same behavior you would get if you had an almost-dead battery installed, and actually pushed the BIL). This happens even if I connect a 95%+ charged battery (so it's giving the behavior of a low-charge battery connected and the button being pressed every time a full-charged battery is connected to the board, no need to even push the button, it happens automatically). This almost makes it seem that (1) the board thinks the BIL *is* being pressed, and that (2) it thinks the attached battery is drained even when it has full charge. Again, battery is detected normally and shows proper charge percentage in OSX.

      Let me check BIL_BUTTON for you and get back to you.

      Comment


      • #4
        Hey Duke,

        I got this one worked out. I heated up the SMC a bit, flooded it with flux, and some nasty gunk flowed out from that corner near R5081. I actually reflowed it a bit, gave it a slight tap on that corner, and I think that worked it out. BIL cable/button is working a treat now--thanks! You can mark this one as solved.

        Comment

        thread bottom ad

        Collapse
        Working...
        X