thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

820-2879 green light, not turning on and not charging

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-2879 green light, not turning on and not charging

    This board was sent in as not turning on. The light on the charger stays green and it doesn't turn on when I hit the power button or when I short the onoff pads.

    Here are some measurements I took before replacing the U7200 chip.

    CHGR_DCIN 16.35
    CHGR_ACIN - 4v
    PPBUS_G3h - 12.58
    pp3v42_g3h- 3.41v
    Resistance Pins 17/18 U7000 - 2.9ohms
    Resistance Pins 27/28 U7000 - 20.2ohms
    u5010 voltages were all fine.
    shorted smc_onoff_l to ground and saw the voltage go to 0v on u5010 but still doesn't turn on
    U7200 (Pin 1 - 0v - Pin 6 - 0.78v - Pin 16 - 12.58v)
    SMC_PM_G2_EN - 3.4v
    ----------------------------------------

    Q7221 was showing 3.38v on pin 2 and 0v on the drain Pin 6 so I replaced the TPS51125(U7200)
    There was still 0v on Pin 1 of U7200 so I replaced Q7221. Still made no difference.

    I then checked Pin 16(VIN) of U7200 and noticed it wasn't a stable 12.58v. PPBUS_G3H starts off at 12.58v and quickly goes down to around 5v then jumps back up to 12.58v and repeats. I even took the TPS51125 off of the board and measured and PPBUS_G3H still does the same thing.

    What could be causing this?

  • #2
    SMC doesn't get 3V_S5 on time and resets ISL6259 I suppose; duke explained this somewhere...
    First of all, check resistance to ground on L6995; 200K resistance scale, not diode mode.
    If get less than 30K trash the board; this means bad MCP almost all the time.
    If seems to be good, check if VREGx outputs of U7200 are steady.
    Also check if any pulse appears at L7220.
    If you remove Q7221, both L7220/60 must get voltage; at least pulses.

    Comment


    • #3
      Resistance to ground on l6995 shows around 2.5Mohms
      Pin 8 VREG3 - 0.73v and goes down. I think it shows 0.73 when PPBUS_G3H is 12.58v
      Pin 17 VREG5(P5V_S5_LDO) - around .35v and slowly goes down then comes back up

      Pin 1 of L7220 is 1.07v when I first plug in charger then goes all the way down to 0.1v then back to 1.07v and repeats.

      It sounds like I need to make ppbus_g3h steady before anything else will work.

      CHGR_ACOK pulses from 3.27 down to 3.11v. L7030 is 0.477 in diode mode
      Last edited by ytesfay80; 03-19-2017, 12:38 PM.

      Comment


      • #4
        TPS51125 replaced?

        Comment


        • #5
          ppbus_g3h was a stable 12.58 but there was no voltage on ENTRIP1 before I replaced the tps51125 previously. After I replaced it thats when ppbus_g3h started fluctuating but even when I removed the tps51125 from the board it was still fluctuating.

          I have one more of these in my spool and I didn't want to waste the last one if that wasn't the issue.

          Should I go ahead and replace it again?

          Comment


          • #6
            What kind of voltage are you searching at ENTRIP1?
            The normal value (enabled) is 0.87V...
            I suspect bad solders at new TPS51125; check for short on L7220/60 now.
            Put back original chip and post some voltages.

            Comment


            • #7
              I was always getting 0v on Pin 1 of U7200 and R7271.
              With the replacement TPS51125 on the board here is what I got.
              L7220 in diode mode - 0.152v
              L7260 in diode mode - 0.447v

              I put the original TPS51125 on the board and the same thing is happening with PPBUS_G3H and 0v on Pins 1/6 of U7200
              L7220 in diode mode - 0.144v
              L7260 in diode mode - 0.438v

              Comment


              • #8
                When PPBUS_G3H is high, VREGx should appear too.
                Is better to use o-scope to see if really rise their normal values; at least don't use auto-range multimeter...
                If remove Q7221, also should get voltages at L7220/60 at same time PPBUS_G3H is high; if SMC_PM_G2_EN is really high, of course.

                Comment


                • #9
                  I measured as soon as the charger was plugged in with my fluke 115 multimeter and pin 17 of u7200 was 4.24v and it quickly goes down.
                  Pin 8 was 2.78v and it quickly goes down towards 0.6v then jumps back up to 2.78v and repeats.
                  SMC_PM_G2_EN is 3.4v.

                  These measurements are with the original TPS51125
                  Last edited by ytesfay80; 03-19-2017, 09:34 PM.

                  Comment


                  • #10
                    Okay so I replaced the ISL6259 and now PPbus_g3h is a steady 12.56v.

                    U7200 was still not getting steady voltage on the VDD Pin so I replaced the TPS51125 with a brand new one and still that didn't solve this.

                    Now when I checked SMC_PM_G2_EN on R7273 there is 0v there, the resistance is around 95k and in diode mode SMC_PM_G2_EN is 0.45v .
                    U7840 voltages
                    Pin 1 - 3.4v Pin 2 - 0v
                    Pin 3 - 0v Pin 4 - 3.38v
                    Pin 6 - 0.98v Pins 7/8 - 0v

                    Pins 8/17 of U7200 are still fluctuating and aren't at the proper voltages.

                    I'm sure this can be fixed because I fixed this this board for the customer a couple of weeks ago. It was not turning on so I replaced the DCIN board and it was working again. After a week they told me it would no longer turn on.



                    Comment


                    • #11
                      Don't be so sure...
                      In the first DC board was fucked some resistor on ADAPTER_SENSE line, which means overvoltage; maybe protection diode.
                      That could slightly affected SMC, which still worked, but now missing SMC_PM_G2_EN could be result of that.
                      Check SMC_RESET_L first, if no light on magsafe.

                      Comment


                      • #12
                        Do you know how SMC_PM_G2_EN could be present before I replaced the ISL6259 but not anymore?
                        I have a green light on the magsafe.
                        ADAPTER_SENSE is 3.38v.
                        SMC_RESET_L is 3.4v
                        U5010 measurements are fine.

                        I've tested with 2 know good dc-in boards.

                        Update: So I removed the TPS51125 from the board and plugged the charger in to see if SMC_PM_G2_EN would come on but it didn't and when I put the chip back on and plugged the charger in the light was dim green and SMC_RESET_L is 0.15v. I don't know what is going on. I've plugged in both DC-in boards and they both are dim green now.

                        2nd update: I looked around the SMC and found R5260 was corroded and in diode mode 0v to ground on both sides. I removed it and the pads are still 0v to ground in diode mode.
                        Pin 2 of R5071(PP3V42_G3H) was also 0v to ground in diode mode. Removed R5071 along with U6901 and still shorted to ground.
                        Last edited by ytesfay80; 03-20-2017, 10:42 PM.

                        Comment


                        • #13
                          Crap under SMC? Shorted SMC? Inject voltage on 3V42 and see if anything heats up.

                          Comment


                          • #14
                            "So I removed the TPS51125 from the board and plugged the charger in"
                            So you may have to trash the board now.
                            I suppose one high-side MOSFET got burnt...
                            Never-ever power up a board leaving MOSFETs from a buck converter with the gate floating!!!

                            Comment


                            • #15
                              Okay I removed L6995 and the short was on Pin 2 side so I injected voltage there and the current was showing around 1 amps then it just started showing 0 amps and the short was gone. I put L6995 back on along with U6901 and now the green light is back.
                              PPBUS_G3H is showing 12.58v then it will just go to 4v and quickly down to 3v then back to 12.58v for a couple seconds then repeats.
                              SMC_PM_G2_EN is back at 3.4v.
                              C7273(PP5V_S5_LDO) pulses from 4.7v and goes down.
                              C7270(5V3V3S5_REG3) pulses from 3.33v and goes down as well.
                              I need to get PPBUS_G3H stable as I did before. I'm not sure if these ISL6259s that I am getting from my spool are bad because I've replaced a few different ones and sometimes I get different voltages on PPBUS.

                              Also, R5260 is still showing 0v to ground in diode mode on both sides.

                              Comment

                              thread bottom ad

                              Collapse
                              Working...
                              X