thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

820-2850 Boards that won't power on with heatsink attached

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-2850 Boards that won't power on with heatsink attached

    I received in a large shipment of 820-2850 boards that someone had replaced the GPUs on (uh oh). They obviously didn't realize that the issue with these boards is the tantalum cap, so they just replaced the GPU (or at least re-flowed them) to attempt repair on the boards. I have around 10 of these, all identical condition; no other work done except GPU clearly reflowed (epoxy missing, flux residue, etc). Well, the first 3 I've looked at (hoping that whoever reflowed the GPUs didn't kill them) all have the same weird symptoms: board powers on and chimes only when a heatsink is not attached. As soon as I attach a heatsink, they stop powering on; specifically, they reach s0 (pp5v_s0 present and GPU and CPU both get warm), but no fans/chime/boot, etc. As soon as I remove the heatsink, boards power on again.

    So this is clearly looking like some sort of screw up in the reflowing/replacing of the GPU on these; does this sound like there's an issue with the solder balls/pads/traces, or maybe some glue underneath the VRAM chips? I noticed whoever reflowed/replaced the GPUs did not remove the VRAM epoxy/glue. Would this cause issues like this where the board will power on without a heatsink attached, but as soon as the pressure (I'm assuming) from the heatsink is applied and is pressing down on the GPU, that it's causing no-power issues?

    Very strange one here. Since I don't do large chipset BGA rework, I don't know what sort of possible oversights in the process can result in issues like this one. I figured I'd ask to see if anyone had any ideas. I hate to scrap the boards, but none of them power on (so far) with a heatsink attached.

  • #2
    You tried another heat sink? I have had heat sinks that someone made so hot the solder on them melted and deformed, it shorted out the caps on the CPU/GPU.

    Comment


    • #3
      Ive seen this a number of times. If you loom at the copper contact point o the heatsink it will be depressed. Causing a short on the caps. Replace heatsink. Its a simple fix

      Comment


      • #4
        Hey Duke, I was just coming back to post an update; I noticed on both of the heatsinks I pulled out (and were testing these boards with), that they BOTH had deformed solder in little "peaks" that were--you guessed it--shorting the caps on the GPU/CPU when I attached them. I found it out after noticing the two heatsinks had a "recessed" GPU copper pad; on the 3rd heatsink I tried, that copper pad is raises/level with the rest of the heatsink (not recessed), so it gives more "clearance" for the surface caps of the GPU; also, this one had no deformed solder.

        Really, really strange. Thanks, Duke, I think that's going to solve it.

        Comment


        • #5
          Someone put the thing in an oven with the heat sinks attached, that is how this happens.

          Comment

          thread bottom ad

          Collapse
          Working...
          X