thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

820-2850 ppbus_g3h

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-2850 ppbus_g3h

    I'm having a hard time with this particular board. It's an 820-2850 with no power:

    1. PPBUS_G3H bounces from 12.6v down to 3,5v, then back up. SMC_PM_G2_EN is also pulsing, as are my S5 rails, fan move just a few.
    2. PP3v42_G3H stable at 3.42v. Green light solid.
    3. Resistance at U7000 (17/18, 27/28) is normal (~3ohm and ~20ohm). Pin 3 of U7000=4V.
    4. No power from charger or battery, however, PPBUS does NOT pulse when a battery is connected only (i.e., with battery plugged in, ppbus stays steady), however, the board still will not power on with battery.
    5. I can't find a short anywhere; I've checked pp3v3_s5, pp5v_s5, pp3v3_s3, pp5v_s3, pp5v_s0, pp3v3_s0, pp1v05_s5, PPBUS, PP3v42, etc. Couldn't find a short anywhere that might be causing the board to cycle.
    6. SMC_RESET_L is stable at 3.4v, however, it drops to 3.3v for a split second every time the board cycles/rails fluctuate.
    7. R7020/R7050 measure fine.
    8. no liquid or trace on the board.
    9. what can i do? do you have some idea?
    thanks

  • #2
    Power cycling. Is CPU VCore pulsing too?

    Comment


    • #3
      Ppvcore_cpu_s0 = 0v
      thanks for your help

      Comment


      • #4
        PPBUS_G3H fluctuates, is not a classic power cycling...

        Stil the same if battery and charger both connected?
        Remove F7040 and see if get stable voltage at C7040.

        Post voltages at U7000, pins 9 & 15.

        Comment


        • #5
          Try to power it on with SMC bypass, must be a sensor issue, look closely with microscope.....
          Only charger what do you have on CHGR_DCIN and SMC_BC_ACOK?

          Comment


          • #6
            Battery & charger both fluctuate between 11,55V -> 12,46V
            i Remove F7040 & i measure on C7040, 12,59V and slow fall to 4V in 3 sec and cycling again.
            U7000 9=0V 15=0V
            CHGR_DCIN = 16,5V stable
            SMC_BC_ACOK=3,25->3,3V
            what is SMC bypass?

            Comment


            • #7
              I find smc bypass, i press power button and plug the magsafe, nothing on the mac (with or without the battery).

              Comment


              • #8
                Issue around the TPS51125 possibly. If S5 power good is not coming on PPBUS will start to cycle.

                Comment


                • #9
                  i don't find anything near TPS51125, seems clean no liquid.
                  S5 rise 5V and fall directly.
                  PP5V_S3 stay at 0V
                  5V3V3_REG_EN=3,3V
                  Last edited by raainxx; 09-03-2018, 12:43 PM.

                  Comment


                  • #10
                    "If S5 power good is not coming on PPBUS will start to cycle"
                    You didn't post P5V3V3_PGOOD yet.
                    PP3V3_S5 should appear first at L7260; this requires P3V3S5_EN.
                    Do you get any pulse on these places at least?

                    Comment


                    • #11
                      P5V3V3_PGOOD = 0V
                      L7260 pin 2 increase at 3V & fall to 0V
                      P3V3S5_EN =3,4V fix

                      Comment


                      • #12
                        Either bad TPS51125 or an overload on the 3v3_s5 rails.

                        Comment


                        • #13
                          ok i try to change TPS51125 but same problem.
                          3v3_s5 change between 0V to 3,3V but how can i find an overload on this rail? no short 4,2Kohm
                          thanks

                          Comment


                          • #14
                            Check all other rails for shorts again. 5V_S3 is the first suspect.

                            What is 3V3_S5 doing with a battery and charger connected?

                            Comment


                            • #15
                              PP3V3_S3 is in short. i remove C3618, now work well.
                              Thanks for your helps

                              Comment

                              thread bottom ad

                              Collapse
                              Working...
                              X