thread top ad

Collapse

Announcement

Collapse
No announcement yet.

820-3115-b ppbus_g3h 12.3v

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-3115-b ppbus_g3h 12.3v

    820-3115-B
    not charging battery



    ​​​​​​Irregular readings I noticed:

    ​​​​​​PPBUS_G3H = 12.3V

    SDA Battery Data Line = 3.2V

    SMC Reset is Good

    Is this a bad SMC?

  • #2
    what about SCL line???

    Comment


    • #3
      3.4V looks good

      Comment


      • #4
        Either bad ISL or bad SMC. You can start by removing edge bonding on SMC and giving it some flux and heat. 12.3 makes me think it’s possible the SMC isn’t dead yet has crap under it

        Comment


        • #5
          Okay I will try this on the SMC, tried a couple new ISL already.

          Before we confirm SMC anything else I can try?
          ​​​​​

          Comment


          • #6
            SCL/SDA lines on diode mode cannot give more than 1% difference, respect to ground.
            If not, remove D6950 and check again.
            BIL connector is supposed to be disconnected, of course.
            Next step, if needed, remove U7000 and test again.
            If still get difference with only SMC on that bus, gues what?
            BTW, try first to reflow it with good flux; could be only crap under SMC...

            Comment


            • #7
              SCL/SDA lines on diode mode give equal reading ~ .5

              Comment


              • #8
                .5 is completely irrelevant...
                As I already told you lees than 5% difference.
                Fot example, .485/.500 is too much difference.
                Try to post correct information.

                Comment


                • #9
                  Yes I can confirm less than 5percent difference on both readings. They are equal.

                  Comment


                  • #10
                    Then change SMC...

                    Comment


                    • #11
                      I noticed on this thread that a similar issue was solved by changing Q7055:

                      https://www.rossmanngroup.com/boards...ixed-via-q7055


                      Should I try this before messing around with the SMC?

                      Comment


                      • #12
                        Is Q7055 bad in your case?

                        "lees than 5% difference"
                        My fault; should be 1%, like in the previous post...

                        Comment


                        • #13
                          How can I effectively test if Q7055 is bad? It gets the 12.3V in but does not go out, pin 4 stuck at 12.3V . Pin 5 has a dropping voltage.. Starts around 4v continually lowers, rate of decrease slows as it gets lower.

                          Comment


                          • #14
                            CHGR_BGATE must go low to enable battery charging.
                            Pin 5 of Q7055 should maintain the battery voltage.
                            Did you try known good battery?
                            Check if R6950 is OK.
                            Last edited by 2informaticos; 11-09-2018, 05:13 PM.

                            Comment


                            • #15
                              R6950 is good, battery is known good

                              Comment

                              thread bottom ad

                              Collapse
                              Working...
                              X