thread top ad

Collapse

Announcement

Collapse
No announcement yet.

820_3787-a no p5vs4_en

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820_3787-a no p5vs4_en

    Its a previous repair attempt,
    ppvrtc is present
    pp5v_s5 and pp3v3_s5 are present
    ppbus_g3h is 12.56
    adapter en and bat_low and pm_dsw_pwrgd is there.
    pp3v3_sus is 3.3v.
    checked resistors around u6100 and they look fine.

    pp5vs4 comes for few seconds when adapter is plugged in and then it goes to 0


    Followed enable pin(4) of u7501 and checked for pm_slp_s5_l and its 0 volts and same goes for smc_s4_wakesrc_en .
    i have replaced u7501 just to be sure that its not pulling enable signal low but the result was same. So i removed u8170 and measured pins without it and there was 5 volts on pin 4 which is s4_pwr_en, as far as i know there shouldn't be anything on pin 4 if u8170 was missing

    and p5vs4 comes without u8170 and it stops when i put it back

    any ideas what i should do next
    Last edited by PPVCC_S0_CPU; 11-09-2018, 05:14 AM.

  • #2
    U8170 can only pull down the output; doesn't have a pull-up resistor inside...
    Removing it, output remains at high level.

    Toggle SMC_ONOFF_L signal and see if all PM_SLP_Sx_L signals react.
    Then check if the power supply correspondintg of each signal give something on the output.
    Is better to use an o-scope for this purpose.

    Did you try to start in SMC bypass mode?
    Are you using original Apple 85W charger?

    Comment


    • #3
      Originally posted by 2informaticos View Post

      Did you try to start in SMC bypass mode?
      Are you using original Apple 85W charger?
      yes i am using original 85w adapter.
      can you tell how to start in smc bypass mode?

      Comment


      • #4
        Press power button, connect charger and maintain pressed 5-10s...
        You can use SMC_ONOFF_L pads when board is alone on the desk.

        Comment


        • #5

          ​
          Originally posted by 2informaticos View Post
          You can use SMC_ONOFF_L pads when board is alone on the desk.
          ​​​​​​Thanks, i will try it tomorrow.
          i also noticed that all pins of u6100 are on 3.3 volts except the gnd.
          Last edited by PPVCC_S0_CPU; 11-09-2018, 08:51 AM.

          Comment


          • #6
            Its Its not working on smc bypass mode, i removed u6100 and fans started spinning and all power rails comes up.
            i can see light in usb mouse when its plugged in
            Last edited by PPVCC_S0_CPU; 11-09-2018, 07:20 PM.

            Comment


            • #7
              Try new BIOS, with clean ME...

              Comment


              • #8
                Originally posted by 2informaticos View Post
                Try new BIOS, with clean ME...
                I will try it on Monday, i measured resistance to ground on cpu vcc rail and it was around 0.7 ohms and it gives 0 volts drop on diode mode. Is this normal?? I tried removing 3 chips for cpu vcc and powered it, the fans starts spinning too(didn't removed u6100 this time) but when board is powered without u6100 cpu vcc shows 1.7 volts.

                Comment


                • #9
                  CPU VCORE has very low values...

                  Comment

                  thread bottom ad

                  Collapse
                  Working...
                  X