thread top ad

Collapse

Announcement

Collapse
No announcement yet.

MBA: Fan spin, chime, backlight no image

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MBA: Fan spin, chime, backlight no image

    Any classics for the above?
    Posts fine.

  • #2
    Tried another screen? Does it boot to a question mark folder with no SSD plugged in internally?

    Comment


    • #3
      Not yet tried another screen. But there is backlight.
      No question mark folder. Will try an external monitor in the morning though .

      Comment


      • #4
        Should add that I bought this one on eBay as the seller said it had been "diagnosed" by Apple as a dead logic board.

        Comment


        • #5
          It could be a board problem, but best to try another screen first. If no success, then could be a BIOS issue

          Comment


          • #6
            Thanks John
            i have a compatible display but it's on my daily driver and I'm in meetings much of the next while. So it may be a fortnight or so before I can spare it more's the pity .

            Comment


            • #7
              Do you get black, or white screen?
              If no result testing known good (and compatible) screen, then come back with board model.
              Then we see what to check...

              Comment


              • #8
                White screen. Chimes and posts. Doesn't boot from external drive or internal ssd. It's an A1369 mid 2011. I will pull the board later today but as per above I won't be able to test with a screen assembly for quite a while.

                Comment


                • #9
                  it's an 820-3023A board. I don't have boardview and schematics for that yet so another reason for debugging to be delayed.

                  no orange light on charger but the fan spins, the device chimes and the CPU and PCH get warm as usual. 25v or so near the LCD. seemingly a little low voltage on some of the coils near the CPU (around 0.5v). When I get the schematics I will test some more and post back.

                  Comment


                  • #10
                    As this is display port, backlight with white screen should be display problem; TFT matrix is not powered.
                    Be sure is pure white, not the classic "dirty" white, which means image present; don't you get question mark folder?

                    Comment


                    • #11
                      I will take a photo later. No question mark folder .

                      ​​​

                      Comment


                      • #12
                        on balance I would say it is more 'grey' than white. but the grey of a diffused backlight?

                        photo here:

                        Comment


                        • #13
                          If is grey means TFT matrix is active.
                          Tested external video?
                          Did you try new BIOS with clean ME?
                          Also try to start from USB pendrive.

                          Comment


                          • #14
                            No luck with external video (thunderbolt)
                            no boot from external drive (external SSD)
                            No keyboard light on the shift lock. and kb backlight not illuminated

                            I haven't done a new bios on this type of logic board. Is it swapping the flash chip out or do I re-flash this chip? In which case what is the process for that (on other devices, such as car flashroms, I tend to use an arduino to write via SPI but there is a probably a better/easier method for macbooks)!

                            Comment


                            • #15
                              TL866, or other available BIOS programmer.
                              Remove the chip is the best and safe way to do it.

                              Comment

                              thread bottom ad

                              Collapse
                              Working...
                              X