thread top ad

Collapse

Announcement

Collapse
No announcement yet.

820-3332-A doesn't work properly with external display

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-3332-A doesn't work properly with external display

    This board has problems when external Display is hooked up to Thunderbolt port. Internal and external displays stay black until you close and open the lid a few times. Then they both work properly.

  • 2informaticos
    replied
    Run heaven on it at least few hours...

    Leave a comment:


  • djdblaster
    replied
    I ended up reflowing only MUX. Computer works normal so far... I guess marked as solved?

    Leave a comment:


  • 2informaticos
    replied
    Tried to reflow/resolder U8900?

    Leave a comment:


  • djdblaster
    replied
    SMC_LID 3.4V
    J9000 no voltage on pins 28-30, with or without screen.

    Leave a comment:


  • JohnB8812
    replied
    This sounds like U8900 tbh...resolder it.

    Leave a comment:


  • 2informaticos
    replied
    Understood now.
    For the repair, continue with internal LCD only.
    Check SMC_LID and voltage for pins 28-30 of J9000.
    In the first few seconds, you must get 5V there; even without LCD connected.
    If LCD is connected, LCD_HPD should go high.
    Once LCD is recognized by PCH, all these should stay high and also image/backlight must come on.

    Leave a comment:


  • djdblaster
    replied
    No. In order to get image on internal display, external has to be connected and lid closed/open a few times. Then it works normal.

    Leave a comment:


  • 2informaticos
    replied
    Do you always get normal image on internal LCD?
    The problem appears only when external monitor is connected?

    Leave a comment:


  • djdblaster
    replied
    Any ideas maybe? Board is super clean.

    Leave a comment:


  • djdblaster
    replied
    I tried with El Capitan. Nothing on screen.

    Laptop starts with black screen, nothing can be seen using flashlight.

    For backlight LCD_BKLT_EN is missing. Goes straight to U9100 (eDP MUX sheet). So something with MUX then since I see HDMI and DP involved on this sheet?

    Leave a comment:


  • djdblaster
    replied
    Sure. I'll go ahead and try.

    How about the quesiton mark folder? Should it always be there independent of OSX?

    Leave a comment:


  • 2informaticos
    replied
    Some backlight issues have been reported for High Sierra...
    You don't lose anything by trying.

    Leave a comment:


  • djdblaster
    replied
    SMC_LID 3.42V with display only connected, outside the housing.

    SMC and PRAM no luck.

    Do I still have to try El Capitan? I don't see how that would be connected to no image and no backlight. I would be happy with a question mark folder screen.

    Leave a comment:


  • djdblaster
    replied
    Not yet, but I do have one drive with it which could be put into external housing.

    Leave a comment:

thread bottom ad

Collapse
Working...
X