thread top ad

Collapse

Announcement

Collapse
No announcement yet.

imac 21, 820 4668 - Turn ON but don't show image

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Noguinfor
    replied
    Thank you Mr.Vali ! i agree with you.. i hate this new models with PCH integrated in CPU! If the PCH was separated off CPU i can easily replace for a new one.. but this processors are the only ones i don't know to remove without bent!

    You can close this post

    Best regards

    Leave a comment:


  • 2informaticos
    replied
    U6200 is only power supply for the audio codec.
    Something else happened to block the start sequence.

    As I mentioned before, could be PCH issue...

    Leave a comment:


  • Noguinfor
    replied
    hey,

    without U6200 this board don't turn on! only turn on the first led!

    Could it be bios problem? i think, I will assume as a processor problem!!

    Leave a comment:


  • 2informaticos
    replied
    You can leave U6201 unsoldered, untill get the board booting.
    You can also remove U6200, just in case.

    U6201 is directly connected to PCH.
    I hope you are not in the worst scenario...

    Leave a comment:


  • Noguinfor
    replied
    Yes i check for usb activity and I assure you that it has no connectivity. already check in exernal monitor as also with original LCD!

    when i turn on the motherboard with only DC power supply only consume 0.6A .. already try to boot in bypass but same history no usb activity!

    It's not the first time this happens to me in this model. usually only needs to replace U6201 and solve the problem! but this one no! =(

    you have more ideas ?? thanks

    Leave a comment:


  • 2informaticos
    replied
    If you get voltage even on CPU core, then check for USB activity.
    Did you connect external monitor for test?

    Leave a comment:


  • Noguinfor
    replied
    PP1V2_S3 = 1.193V

    ALL COILS have voltage!!

    this one don't have external rams! Rams it's onboard!

    thanks

    Leave a comment:


  • Noguinfor
    replied
    3V3_S0 - 3.3V
    5V_S5 - 5.072V

    PPCPU_VCC_S0 = 1.742 (BOUGHT COILS)

    PP1V05_S0 = 1.050v

    Leave a comment:


  • 2informaticos
    replied
    Check exact voltage for 3V3_S0 and 5V_S5.
    U6201 can only be damaged by an overvoltage.
    You can continue the repair without it, untill get the board booting.

    If LE0302 is on, means almost all voltages are present; maybe excepting CPU ones.
    Check on all coils.

    Did you try one known good RAM module at a time, on each slot?

    Leave a comment:


  • Noguinfor
    started a topic imac 21, 820 4668 - Turn ON but don't show image

    imac 21, 820 4668 - Turn ON but don't show image

    Hey,

    working on 820 4668 and this one came with the problem don't turn ON! "only with first led on"

    i connect the power supply on board and i noticed that u6201 get's hot! i try to replace for a new one but went wrong the component "burn" again but the machine turn's on without press power button!

    i take off the component and the machines turn on without press power button but only turn on the second led! No image and No USB activity!

    With U6201 out, I already checked for other components heating but I did not find any. u2800 heat a bit but i think it's normal!

    suggestions for this ??

    Thanks

thread bottom ad

Collapse
Working...
X