thread top ad

Collapse

Announcement

Collapse
No announcement yet.

820-3787a no backlight image can be seen liquid damaged.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-3787a no backlight image can be seen liquid damaged.

    Gday guys I'm using schematics for 820-3332 so hope layout is similar. unit has corrosion on c8513 PP1V5R1V35_S0GPU would this cause no backlight? because I wouldn't think so unless this rail must be complete before backlight shows up. or is it as simple as replace backlight driver? I'm getting 0.560 Diode on L9000. I'm not 100% familiar with this retina model so any help would be great. I'm getting 12v on both sides of the fuse.

    Read more........

  • #2
    820-3787 schematic and boardview available, search better the Internet.

    Do you get image, only missing backlight?

    Comment


    • #3
      Yeah get the correct schematic first. What voltage do you get on BKLT output on the bigger BKLT caps?

      Comment


      • #4
        there is 0v on backlight output. yes i can see an image but not backlight
        Read more........

        Comment


        • #5
          Check diode mode to ground at pin 1/J8300 w/ and w/ LCD connected; no power applied, of course.
          Also check if F7700 is OK.

          Post voltages for Q7706 and U7701, pins 5, 18, 17, 11; LCD connected this time.
          Be sure to have continuity from U7701 to R7708/09.

          Comment


          • #6
            R7708/09 have cont. R7709 is 16K it should be 150K is this the feedback?

            F7700 is fine

            J8300 P1 with lcd on is 0.033 Diode mode
            J8300 P1 w/o lcd is 1.149 Diode mode

            Q7706 P1 -0.060 P2 -0.060 P3 12V P4 12,3V P5 0.060 P6 0.060

            Hope this helps
            Read more........

            Comment


            • #7
              U7701 voltages P5 OV P11 11.93V P17 0V P18 0V
              Read more........

              Comment


              • #8
                u7701 Not turning on?
                Read more........

                Comment


                • #9
                  Check R7743/44.
                  Be sure no short on pins 5 & 18 of U7701, if you need to replace them.
                  Check first if =PP5V_S0_BKLTCTRL arrives to R7743/44...

                  Comment


                  • #10
                    Im getting 5v on both those resistors R7743/4 both 2.5Ohms and both are 0.374 in diode mode
                    Last edited by PCTRONICS; 03-23-2019, 09:06 PM.
                    Read more........

                    Comment


                    • #11
                      There is nothing wrong with the driver you said you have 0.003 with the screen connected but it 1.1 without. Replace the blown fuse and measure again with a KNOWN GOOD screen

                      Comment


                      • PCTRONICS
                        PCTRONICS commented
                        Editing a comment
                        What fuse?. i said i had 12v on both sides. the fuse F7700 is fine unless you are referring to another one. ill try another screen.

                    • #12
                      "J8300 P1 with lcd on is 0.033 Diode mode
                      J8300 P1 w/o lcd is 1.149 Diode mode"
                      Ooops, I didn't read this full.
                      You have LCD assemblw problem; video cable, or display itself (more probably).

                      But confirm again all measurments, because you posted 0V on pins 5 & 18 of U7701 first time and 5V next post.
                      Always measure voltages with LCD connected.
                      Please provide accurate information.

                      Comment


                      • #13
                        My apologies i measured U7701 with the machine off. the second measurement was with machine on. thanks am getting a screen now. will update in the next hour. both pins 5 and 18 are getting 5v.
                        Read more........

                        Comment


                        • #14
                          Thanks for your help guys. it was the screen after all. Oh well i guess i better ring the customer and tell him the bad news.
                          Read more........

                          Comment

                          thread bottom ad

                          Collapse
                          Working...
                          X