thread top ad

Collapse

Announcement

Collapse
No announcement yet.

820-3437 Shuts Down during boot.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-3437 Shuts Down during boot.

    Came in with liquid damage- Computer turns on, but suddenly powers off while trying to load OS from either the internal SSD or external USB drive. The crash usually takes place towards the end of the boot process, but not specifically the same time every time. I have found if I disconnect KB/TP cable the OS will boot into the OS without crashing. I so far have tried new KB/TP Cable, new TP, new KB and have replaced the KB/TP connector as well.

    Visibly Affected areas-

    U1930/ replaced
    C7601/ replaced
    C5021/ replaced
    L5001/ replaced
    KB Connector/ replaced

    Minor pad damage around SMC





  • #2
    Reflow the SMC just in case. The trackpad does attach to the PCH, so hopefully, that is not the issue. I would bet on crap under the SMC tho

    Comment


    • #3
      Thanks John, appreciate it dude!

      Comment


      • #4
        That was it! Thanks again man, have a good one.

        Comment


        • #5
          Nicely done!

          Comment


          • #6
            Hello, this board just came back from customer experiencing the same issue. turns on oots, but crashes randomly. It will still boot completely normal if TP/KB cable is unplugged. This time I replaced the SMC and repaired a small pad (93) as well. Issue also occurs in SMC bypass mode. I have replaced the connector and have checked values on R4850- 53 and r4860. The board is actually a 00165 (sorry about that, I dont know why I put 3437).

            Thanks, sorry for the repeat issue.

            Comment


            • #7
              Monitor SMC_ONOFF_L signal, when trackpad connected.
              You can also cut off SMC_ONOFF_L line to J4800 and see if it works good with trackpad connected.

              Comment


              • #8
                SMC_ONOFF_L stays between 3.399V - 3.4 V the entire time. Also disconnected SMC_ONOFF_L from the trackpad connector without change in behavior.

                Thanks.

                Comment


                • #9
                  Now disconnect SMC_LSOC_RST_L from J4800 and test it...

                  Comment


                  • #10
                    With SMC_LSOC_RST_L disconnected, same result.

                    Comment


                    • #11
                      Are you 100% sure the issue comes up only with trackpad/keyboard connected?
                      Disconnect trackpad flex and test it half day, even more.

                      Also let trackpad connected, but disconnect keyboard flex from trackpad board.
                      Test again for long time.

                      Comment

                      thread bottom ad

                      Collapse
                      Working...
                      X