thread top ad

Collapse

Announcement

Collapse
No announcement yet.

820-2530-A does not recognize battery x though battery symbol

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-2530-A does not recognize battery x though battery symbol

    This machine works fine on mag charger, but apparently has no connection to battery: will shit down when mag is removed. Tried new battery : same x through the battery symbol. I did the SMC reset, but it did not respond as other Mbps have done in the past. Basically ignored it, no changes on mag light nor sounds. PR reset did respond normally. I ran ASD and it showed an error in battery temp sensor. I did not take out the board yet, hoping for some guidance where to start. Rookie alert..
    Last edited by jurgenkoppen; 03-21-2019, 11:00 PM.

  • #2
    Any history available?
    Disconnect BIL first and see if battery appears in OSX.
    Post PPBUS_G3H w/ and w/o battery connected; charger connected in both cases, of course.
    Post diode mode (red probe to ground) on SCL/SDA lines and voltage too.
    Be sure R6950 is OK.

    Comment


    • #3
      When no battery is in the machine I have the same battery symbol in OSX crossed out, same as when the battery is connected.
      The history is that there is no liquid spill detectable, machine works actually really well on AC, and is very clean inside.
      PPBUS_G3H at F7000 is12.63V w/o battery, reads 12.21V with new battery ( and 9V with the old battery)
      SCL/SDA lines are both 522 ohm in diode mode, and read each 3.4V w/o battery and same with new battery
      R 6950 is within specs...

      Comment


      • #4
        If PPBUS is 12.6 without the battery, you have bad batteries or an issue with the BIL. Are you testing without the BIL plugged in?

        Comment


        • #5
          Oh, I think I misunderstood. I tested without BIL plugged in, after I removed the board. I thought with BIL you meant "Battery In Loup" instead of "Battery Indicator Light" , so I disconnected the battery and thought I followed your instructions. But I see now that you are referencing the J6955 connector. So I can put the board back in and try again...
          Last edited by jurgenkoppen; 03-22-2019, 06:21 PM.

          Comment


          • #6
            Oh yay, thank you, 2informaticos and JohnB, that FIXED it!!!. Without the battery indicator light plugged in everything is fine! Oh good, I needed a success for a change...I will switch the BIL from a donor and be on my way.
            Last edited by jurgenkoppen; 03-22-2019, 06:36 PM.

            Comment

            thread bottom ad

            Collapse
            Working...
            X