thread top ad

Collapse

Announcement

Collapse
No announcement yet.

820-2914-a not turning on.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BCN_Techs
    replied
    It was bad SMC, changed it now it boots, light is ok PPBUS is 12,6 but after apple load stack on white screen. GPU is dead. heat it up and doesnt work. So disabled dedicated GPU and now mac us rinning ok with secondary graphic card.

    Leave a comment:


  • 2informaticos
    replied
    Then try another SMC, from donor board...

    Leave a comment:


  • BCN_Techs
    replied
    Yes, there is continuity from PIN 5 U6900 to pin 3 on dc board.
    Last edited by BCN_Techs; 06-27-2019, 12:10 PM.

    Leave a comment:


  • 2informaticos
    replied
    "Pin 3 magsafe"
    I do NOT mean J6900, but DCIN board...

    Leave a comment:


  • BCN_Techs
    replied
    P.S. Central pin of magsafe is 3 (GND)

    Leave a comment:


  • BCN_Techs
    replied
    Ok, thanks about PPBUS


    SMC_BATLOW_L and PM_SLP_SUS_L 0V

    There is no continuity from Pin 3 magsafe and u6900 pin 5

    Leave a comment:


  • 2informaticos
    replied
    So PPBUS_G3H is not OK at all.
    Do NOT assume things like this in the future.

    "PM_BATLOW_L - 0V"
    Also no good.
    Post SMC_BATLOW_L and PM_SLP_SUS_L too.

    Check continuity from U6900 to DCIN central pin (Magsafe connector).

    Leave a comment:


  • BCN_Techs
    replied
    PPBUS 12.2V, is that means SMC is not working?

    U6900

    Pin 1 ,4,5 3.4V

    U6901

    Pins 1,2, 3.3 V
    Pin 3 0V
    Pin 4,5 3,4 V


    SMC_RESET_L - 3.4V
    SMC_ADAPTER_EN - 0V
    PM_BATLOW_L - 0V
    PP3V3_S5 - is present
    3V3_SUS - 0V


    The charger is 85W and already tried know working dc in.

    Leave a comment:


  • 2informaticos
    replied
    "It must be about 18 and it is 17V."
    WOW, such a "BIIIG" difference!!!
    Do you really think is that relevant???

    "PPBUS is ok."
    12.2V, or 12.6V?

    Post U6900/01 voltages.
    Did you try another DCIN board?

    What about SMC_RESET_L, SMC_ADAPTER_EN, PM_BATLOW_L, 3V3_S5, 3V3_SUS?
    Are you using 85W charger?

    Leave a comment:


  • BCN_Techs
    replied
    Again GPU? this week is GPU deatch week. Any way to check it and be sure that GPU is dead?

    PDCIN is low anyway. It must be about 18 and it is 17V.

    Leave a comment:


  • JohnB8812
    replied
    Just saying once you fix this it will have a dead GPU...

    Leave a comment:


  • BCN_Techs
    replied
    Update. I repassed ISL and changed it again. Now not fluctuating sometimes. Sometimes it is going up and down. PPBUS is ok. Still no green light on charger.

    Leave a comment:


  • BCN_Techs
    started a topic 820-2914-a not turning on.

    820-2914-a not turning on.

    Hi,

    I have got 820-2914-a that is not turning on. No light on magsafe. Checked ISL62 and it seems be ok. Reistance between 17/18 and 27/28 is fine.


    PPBUS is los 1,7V

    PPDCIN_G3H is fluctuating from 16,8 to 17,1.

    Checked resistance arroung ISL and also didnt find nothing wrong.


    PP3V42_G3H - 3.45V.

    Before checking S3 and S5 lines. Is there any idea why it is fluctuating if ISL and all componentes arround are ok?


    Thanks

thread bottom ad

Collapse
Working...
X