thread top ad

Collapse

Announcement

Collapse
No announcement yet.

820-3437-B dead

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-3437-B dead

    Hi!

    I have here a 820-3437-B board: fan is not spinning, but i have orange/green magsafe light.
    No water damage, no drops and under scope inspection everything seems to be nice and clean.
    Where you suggest start checking?

    Thanks!!!

  • #2
    Posting some (exact) voltages from the board.
    Like 3V3_S5/SUS and PPBUS_G3H.
    Good if you post more...

    Comment


    • #3
      Post voltage for PPBUS_G3H, PPVRTC_G3H, PP5V_S5, PP3v3_S5, PP5v_S4RS3

      Comment


      • #4
        Originally posted by 2informaticos View Post
        Posting some (exact) voltages from the board.
        Like 3V3_S5/SUS and PPBUS_G3H.
        Good if you post more...
        Here it is:

        PPBUS_G3H 8.2v
        PPVRTC_G3H 3.3v
        PP5V_S5 5v
        PP3v3_S5 3.3v
        PP5v_S4RS3 0v


        Thanks!

        Comment


        • #5
          Your issue is PPBUS it should NOT be 8.2 but rather 8.6. SMC_RESET_L voltage? This is looking like a bad SMC to me. Post that voltage first

          Comment


          • #6
            Originally posted by johnb8812 View Post
            your issue is ppbus it should not be 8.2 but rather 8.6. Smc_reset_l voltage? This is looking like a bad smc to me. Post that voltage first
            smc_reset_l 3.3v

            Comment


            • #7
              If you get orange light, SMC_RESET_L should be good.
              3V3_S5 present also means SMC_PM_G2_EN is OK.

              I asked about 3V3_SUS and no response.
              If miss it and also PM_SLP_SUS_L, then check all (4) RTC signals from page 12.

              Comment


              • #8
                Originally posted by 2informaticos View Post
                If you get orange light, SMC_RESET_L should be good.
                3V3_S5 present also means SMC_PM_G2_EN is OK.

                I asked about 3V3_SUS and no response.
                If miss it and also PM_SLP_SUS_L, then check all (4) RTC signals from page 12.
                Sorry, i've missed that.
                3V3_SUS: 3.3v

                Comment


                • #9
                  And
                  PM_SLP_SUS_L is 1.06v

                  Comment


                  • #10
                    Is PPBUS 8.2 or 8.6? If 8.2, you have a bad SMC.

                    Comment


                    • #11
                      Originally posted by JohnB8812 View Post
                      Is PPBUS 8.2 or 8.6? If 8.2, you have a bad SMC.
                      Tried a mild reflow on SMC, now the fan spins but screen stays black, so i will change SMC.
                      thanks John!
                      Last edited by vsa100; 07-02-2019, 01:28 PM.

                      Comment


                      • #12
                        "PM_SLP_SUS_L is 1.06v"
                        That is bad, should be 3V.
                        Are you sure?
                        Strange to get 3V3_SUS then.

                        If symptom changed after reflowed SMC, reball it.
                        If still the same, then change it.

                        Please do NOT quote entire post visible few centimetres above...

                        Comment


                        • #13
                          Solved: reballed SMC, working perfectly now and passed every test.

                          Thanks!

                          Comment

                          thread bottom ad

                          Collapse
                          Working...
                          X