thread top ad

Collapse

Announcement

Collapse
No announcement yet.

820-3437 PP5V_S5 pulsing from 0 to 5.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-3437 PP5V_S5 pulsing from 0 to 5.

    Hi there,

    Got mba with no liquid damage. Just stopped working. The macchine boots in SMS bypass and working fine but not booting normal way.

    Magsafe led is always greeen. CHecked all main rails and except of PP5V_S5 are presents. PP5V is pulsing constantly.


    Any idea?

  • #2
    I changed U7501 thinking it may help but same result. While U7501 wasn't on board magsafe turns orange as must.

    Comment


    • #3
      "While U7501 wasn't on board"
      Did you power on the board without U7501???
      Check for short on L7520/60 now.

      "The macchine boots in SMS bypass"
      Some sensor blocks the SMC.
      First check AVREF_SMC.
      Next check SMC_DCIN/BMON_ISENSE and SMC_DCIN/PBUS_VSENSE.

      Post exact PPBUS_G3H voltage and check resistance between pins 17/18 and 27/28 of ISL6259.

      Comment


      • #4
        "Did you power on the board without U7501???"
        No, just plugged magsafe and light turned orange.

        "Check for short on L7520/60 now"

        Checked and not shorted.

        AVREF_SMC 3,3V

        SMC_DCIN_VSENSE pulsing 0-1,5V
        SMC_DCIN_ISENSE - 0.03-0.06 V pulsing
        BMON_ISENSE - pulsing to 0-1,2V
        SMC_DCIN/PBUS_VSENSE. pulsing 0-0.03 every half second.

        PPBUS is 8.62 and constantly goes down 8,5, pulsing too.

        ISL6259

        17/18 3.3
        27/28 20 ( it was first i checked.)

        Comment


        • #5
          "PPBUS is 8.62 and constantly goes down 8,5, pulsing too."
          You didn't mention that before.
          If board works with battery, then could be leakage on the input stage.

          "No, just plugged magsafe and light turned orange."
          3V3/5V MOSFETs got voltage, you've lucky nothing burnt.

          "BMON_ISENSE - pulsing to 0-1,2V"
          1.2V is high enough to block the SMC.
          "17/18 3.3"
          Did you check directly between U7100 pins?

          Try fake charger, or lab power supply with 60/85W cable.

          Comment


          • #6
            Yeah never ever apply power to a board without the TPS or bad things will ensue...

            Comment


            • #7
              with fake charger doesnt boot .

              "Did you check directly between U7100 pins?"

              Yes.


              With battery connected PPBUS is pulsing 8.42-8.44 battery disconected 8.55-8.62. Doesnt boot with connected battery



              "Yeah never ever apply power to a board without the TPS or bad things will ensue..."

              Ok John, thanks for info


              Any idea what can i do?

              Comment


              • #8
                Check again BMON_ISENSE.
                If still pulses high, change ISL6259.

                Comment


                • #9
                  SMC_BMON_ISENSE now not pulsing its 0.065V and stable. SMC_DCIN_ISENSE still pulsing 0.03-0.06

                  Comment


                  • #10
                    Must be other SMC sensor involved, if it always starts in SMC bypass.
                    Can also be SMC, if never gets orange light.
                    Did you test with correct Magsafe 2 charger?
                    Post exact voltage for PPBUS/PPDCIN_G3H.

                    Comment


                    • #11
                      WIthout battery connected PPBUS is 8.54 than 8.58 than 8.60. PPDCIN pulsing too 19,9 to 20,2V

                      Comment


                      • #12
                        In SMCBYPASS start ppbus is 8,17V. Is that normal?

                        Comment


                        • #13
                          PPBUS_G3H looks correct, even for SMC bypass.
                          Try another SMC.

                          Comment


                          • #14
                            Tried new one. Now i have no green light and 8,18 PPBUS. Do you know if 980 YFC LM4FS1BH 5BB... (original that comes with board) can be replaced by 980 YFC LM4FS1AH 5BB ? Also in PDF says LM4FSXAH5BB

                            Comment


                            • #15
                              "Tried new one"
                              Really new???
                              Why did you buy that?
                              SMC has firmware, need to pick it from donor board, same model.

                              Comment

                              thread bottom ad

                              Collapse
                              Working...
                              X