thread top ad

Collapse

Announcement

Collapse

READ BEFORE REGISTERING SO YOUR ACCOUNT WORKS

In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

2010 MBP works but doesnt charge the battery.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2010 MBP works but doesnt charge the battery.

    No liquid damage, its detecting battery in About. I always seem to replace ISL6259 but my question is "how to tell if it is in fact the ISL?" any help is much appreciated thanks in advance.
    Read more........

  • #2
    Known good battery? Resistance between pins 17/18 and 27/28 of the ISL6259

    Comment


    • #3
      When OSX detects battery, first step is testing known good battery.
      Post exact voltage for PPBUS_G3H and run ASD EFI.

      Comment


      • #4
        can someone please share the BRD. i purchased the pdf but no brd was available.
        Read more........

        Comment


        • #5
          Maybe, if you post 820-xxxx code of your board...

          Comment


          • #6
            820-2915 thanks for any support given
            Read more........

            Comment


            • #7
              Why did you buy schematic, instead of asking here?
              https://drive.google.com/open?id=1Jr...cOgDVUsO__trtN

              Comment


              • #8
                Fair warning this will have a dead GPU tomorrow so yeah

                Comment


                • #9
                  Thanks for the BRD. here is the conclusion.

                  ISL6259 area was fucked. looks like someone gave it a good blowjob with an hot air gun on hi flow and blew shit everywhere. resistor where a cap was supposed to be and so on. dare i say the original fault all along was probably the battery. out of 6 batteries i had they were all broken lol. i tested it with a 13" battery and what do ya know??? it started charging.

                  Thanks once again, this job is done! as for the failing GPU whos gives a daam, some customers love thier shit so much they will literally use it to the death. so long as they are aware of the issue then thats all thatr matters.
                  Read more........

                  Comment

                  thread bottom ad

                  Collapse
                  Working...
                  X