thread top ad

Collapse

Announcement

Collapse
No announcement yet.

iMac 21.5" Mid Late 2015 820-00430-A no clue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • iMac 21.5" Mid Late 2015 820-00430-A no clue

    820-00430-A first LED light comes on, I have never worked on an iMac board so I dont even know how to power this thing with a power supply, boardview and schematics are nowhere to be found.

    Board is clean no visible damage anywhere, board 3v battery was replaced but still no startup.

    Any guidance will be greatly appreciated.

  • #2
    Maybe 820-4668 schematic helps you a bit.
    Taking this as guide, only need to connect 12V at pins 4-6/J6900.
    If first LED (LE0301) stays on, board is in S5 state.

    If CMOS coin cell is removed, board should start by itself.
    Check if you get pulse at any S3/S0 power rail (big coils).
    I recommend you to change Q8450.

    Comment


    • #3
      Thanks, battery removed board not starting, no pulsing on big coils, replaced Q8450 still nothing, U6200 was getting really hot removed it for now as I think the iMac should start even without that one, but nada!

      Comment


      • #4
        If U6200 is same audio power, like in schematic, board can start without it.
        It also means that board achieves S4 state, if that chip heats; is on 5V_S4 rail.
        Can you confirm presence of such voltage on its coil?
        PM_SLP_S5_L should be high.

        Comment


        • #5
          Yes U6200 is audio related, after removing U6200 5V_S4 present on its coil, in fact I am making it to PP1V2_S3 checking Q4020 now but I seem to be stock.

          Comment


          • #6
            I think Im close to finding the problem,

            U8450
            1. 12v
            2.3.2v
            3. 0v
            4. 0v
            5.12v
            6. 12v
            7. 23v
            8. 3.3v

            U6970
            1. 12v
            2.3.4v
            3. 0v
            4. 0v
            5.12v
            6. 12v
            7. 22v
            8. 3.8v

            I don't have any boards that have those chips so I cannot replace them yet, I will order them once I know that is the problem, thanks for all the tips so far, if I fix this one this will be my first iMac fixed.

            Comment


            • #7
              U8450 looks good.
              It doesn't fail, just Q8450.
              Which is also good if you get 12V_S0.
              And of course U/Q6970 both good, as you already got S5 state.
              When corresponding MOSFET is bad, you will not get 22V output from U6970/8450.

              Check if PM_SLP_S4_L pulses at least.
              Trigger SMC_ONOFF_L and check for reaction at PM_PWRBTN_L.

              Comment


              • #8
                The 23v made me think something was wrong since the schematics show 12v on that line.

                PM_SLP_S4_L
                is 3.3v steady I dont know how to trigger
                SMC_ONOFF_L but it is 3.4v steady also PM_PWRBTN_L. is 3.4v steady

                Comment


                • #9
                  If PM_SLP_S4_L is steady high, you should get all S3 voltages; check that.
                  You should see a drop pulse on PM_PWRBTN_L when triggering SMC_ONOFF_L.

                  "I dont know how to trigger"
                  Imagine something like pressing power button; J5120 can be used...

                  Comment


                  • #10
                    I do
                    see a drop pulse on PM_PWRBTN_L when triggering SMC_ONOFF_L or when "pressing power button"

                    Comment


                    • #11
                      Then all PM_SLP_Sx_L signals must pulse.
                      And of course, corresponding voltages should pulse too.

                      Comment


                      • #12
                        None of
                        PM_SLP_Sx_L pulse, the voltage is there but no pulse either with a trigger on SMC_ONOFF_L or a power button press.

                        Comment


                        • #13
                          Ok Im now at PP0V6_S3_DDRVTT that power line is not present in U7300 pin 3 but present on XW7325 but with 1.2v and not 0.6v as the schecmatic shows, Im hoping this will be the culprit...

                          Comment


                          • #14
                            "None of PM_SLP_Sx_L pulse, the voltage is there but no pulse"
                            That is good, if you have stable levels.
                            I said to check for pulse, in case no stable high level...

                            PP0V6_S3_DDRVTT comes from pin 3/U7300.
                            Maybe you didn't have good contact when measured.

                            Looks like you have all voltages on the board.
                            Confirm that for CPU coils.
                            Check for USB activity with mouse/keyboard.

                            Comment


                            • #15
                              PP0V6_S3_DDRVTT not present on pin 3 of U7300 tripple checked it, even gave it a re-solder and nothing, whats also strange is that pin 5 is 0.6v rather than 1.2v as mentioned in the schematics.

                              REG_PHASE_P1V05S0_L is 0v on its coil same with REG_PHASE_CPUVCC_1 and REG_PHASE_CPUVCC_2

                              Comment

                              thread bottom ad

                              Collapse
                              Working...
                              X