thread top ad





In order for your account to be activated INSTANTLY, your PayPal email MUST MATCH THE EMAIL YOU USE TO REGISTER YOUR ACCOUNT ON THIS FORUM!! If your PAYPAL email address differs from your FORUM email address, your account will have to be activated MANUALLY when a customer service agent gets around to it.

I realize this sucks, and I do apologize.
See more
See less

Macbook Pro 2009 17 / 820-2390-A attempt to repair liquid spill

  • Filter
  • Time
  • Show
Clear All
new posts

  • Macbook Pro 2009 17 / 820-2390-A attempt to repair liquid spill

    - I cleaned the board, there where some small areas where you could see a bit of liquid damage. After cleaning it looks ok.

    - Light from power adapter is green

    - Checked the following power rails:

    PPBUS_G3H: 8.4V
    PP18V5_DCIN_CONN: 17.1V
    PP3V42_G3H_REG: 3.4V

    PP5V_S3_REG: 0V
    PP5V_S0_REG: 0V

    PP3V3_S5_REG: 3.3V
    PP3V3_S3_FET: 0V

    Tried to get to the source why PP5V_S3_REG is 0V.
    - Checked U7201(TPS51220) enable:
    - EN1: 0V
    - EN2: 3.4V

    Followed EN1 / P5VS3_EN which is same as PM_SLP_S4_L (double checked voltage also 0), which ends in U1400 (MCP79).

    My only idea left is that the C7812 could be broken and pulls PM_SLP_S4_L to ground. But C7812 looks like it is not put on the board (there was a No Stuff comment on the diagram).

    Followed source where PP3V3_S3_FET is supposed to come from. Ended up at Q7910. Source of the MOSFET is PP3V3_S3_P3V3S3FET, which I measured 3.3V. P3V3S3_SS is around 3.15V, which if I understand it correctly explains that the MOSFET switches PP3V3_S3_FET off. Then I tried to figure out why P3V3S3_SS is 3.15V. This is due to P3V3S3_EN is 0V.
    P3V3S3_EN is PM_SLP_S4_L and so the reason is the same as above.

    Now I'm stuck as I cannot tell why PM_SLP_S4_L is 0V. If anybody has some ideas what to do, I would greatly appreciate it.

  • #2
    Got 1.05V on C7771? Did you use the pads on the board to power on to eliminate a bad keyboard?


    • #3
      Yes, I have 1.05V on C7771 Pin 2.
      I completely removed the logic board from the housing. No keyboard connected. However I just connected the board with the power supply, but did not manually power on the board with the pads.
      I just tried to do that now, but that did not change anything. PP5V_S3_REG, PP3V3_S3_FET and PM_SLP_S4_L are still 0V.
      Is there a way to verify that I have powered on the board correctly? I just connected the two 'PWR BTN' pads for a couple of seconds.


      • #4
        You check PM_PWRBTN_L when you short the pad on the board, it should go low. Also make sure you use a REAL 85W charger!


        • #5
          Thanks, that was a good hint. I changed to the 85W charger and then when I shorted the pads the fans spun up for a minute. However they stopped again while I tried to measure the missing power rails.
          Now the fans not spinning up again and I am back to where I was before.
          PM_PWRBTN_L only goes low while the pads are shorted or will it stay low?


          • #6
            Did you short things out when measuring? Need to start form the beginning now, PPBUS, 3V3_S5, 1.05V, etc.


            • #7
              Sorry, for the long silence. I have been swamped with work.
              I don't think I shorted anything, but I measured everything again. Status is like given in my first post. It also doesn't turn on with the PWR BTN pads.


              • #8
                PM_PWRBTN_L toggling when you short the power on pads?


                thread bottom ad