Search results

  1. C

    A2179 820-01958 no audio from speakers experimentation

    So I had a bit of free time to look through some of my boards with weird issues and I had this 820-01958 which had sound only from headphones - no sound from speakers at all. Troubleshooting got me to SPKRAMP_RESET_L having an odd diode mode reading (0.002) and 20ohms to ground. Obviously went...
  2. C

    Macbook Air A2179 820-01958 Liquid Damage

    No liquid on either touch ID or audio board both clean. All testing I did so far was with those two disconnected anyway - only had the charger alone or the charger and battery connected. Looking at the power on sequence it gets up to PP3v_G3H which is present and stable at 3V. PP5V_G3S is...
  3. C

    Macbook Air A2179 820-01958 Liquid Damage

    So I have an 820-01958 in for fixing now - was liquid damaged but customer neglected to tell us this before we opened the device and found it. So we had liquid damage and a burned port going to the type c ports - we also had liquid damage around the top CD3215 controller. I've replaced the...
  4. C

    820-02098 Water Damage, Charger Stuck 5V 0.2A Draw

    Further visual inspection reveals what looks like a broken component - maybe a diode? Attached a picture, the left side is connected to ground and the right side is not!
  5. C

    820-02098 Water Damage, Charger Stuck 5V 0.2A Draw

    I'll check out 02100 schematic see if I can guess anything based on that. I've tried DFU revive and it doesn't even get detected so that's a no go. Do we know which voltage rail is required to be working on these M1's to get the charger switching to 20v?
  6. C

    820-02098 Water Damage, Charger Stuck 5V 0.2A Draw

    Got an 820-02098 in which had liquid damage. I've gone through the board under the microscope cleaning all areas I could find any issue with and i've run the board through the ultrasonic. I ran through the power on sequence on the repair wiki and found that PPBUS_AON was shorted - i've...
  7. C

    820-1521 Dead Stuck at 5v

    After waiting a couple weeks for U7800 from china received today fitted and machine working normally again. Wish there was a better source for these chips than having to wait weeks from china though!
  8. C

    820-1521 Dead Stuck at 5v

    No output from any of the LDO's out of U7800. Also no lines shorted.
  9. C

    820-1521 Dead Stuck at 5v

    So I got an 820-1521 in today - completely dead no sign of liquid anywhere. No damage visible - the machine is stuck at 5V on both ports. PPBUS is 12.31 PP3V3_G3H_RTC is present. PP5V_G3S and its associated enable is missing. Awake and Sleep voltages are also all missing. Not detected at all...
  10. C

    820-01949-07 Not starting up

    Well after much messing around I managed to get my hackintosh up to 10.15.7 and ran the apple configurator software. It detected the mac in recovery mode and successfully restored it. All working fine now - is this a common issue after SSD power issues?
  11. C

    820-01949-07 Not starting up

    yes that idea did cross my mind but i only have a 2014 13" Macbook Pro. I do not have any newer machines I can use and the hackintosh system I have which does have a thunderbolt 3/type c port on it will not update to 10.15.6 so I can use the apple configurator software! Is there any way of...
  12. C

    820-01949-07 Not starting up

    Right have looked at the power on sequence and it's getting stuck at PMU_ONOFF_L - it drops from 3.3v to 0v when power button pressed but PP3v3_S5 and PP1v8_S5 do not pulse or appear after this. I have got PP5V_S5 present still though
  13. C

    820-01949-07 Not starting up

    Right i've replaced U9080 now and I am getting SSD voltages but the machine is still not powering up. I'll check the power on sequence!
  14. C

    820-01949-07 Not starting up

    cannot see any SSD voltages coming up - with a new battery connected it's not really made any difference - my USB C meter is showing it hovering up to 0.5a and then back to 0A then looping back up to 0.5A draw again. CPU isn't getting warm and no voltages coming other than S5 ones
  15. C

    820-00850 Left Fan Won't Turn off and runs full speed

    Nailed it thanks! Q6000 was missing as was a couple of resistors next to it. Replaced from a donor board and fans behaving normally now. Just got to sort out the customer with a new Touch ID flex cable!
  16. C

    820-01949-07 Not starting up

    Got an 820-01949-07 in today - problem is it won't start up - stripped it down to just the board and charger and it takes 20V 0.09A current draw. Popped it under the thermal camera and the only thing which is heating slightly is U9080 - nothing visible shorted on the NAND power lines either...
  17. C

    820-00850 Left Fan Won't Turn off and runs full speed

    So i got an 820-00850 in today - was originally fully shorted out stuck at 5V which I identified to a burned cap. Now the board turns on and works fine but the left fan as looking at it from the bottom runs at absolutely full speed (right one working normally) and also continues to run after the...
  18. C

    820-00165 Won't Turn On

    Did a bit more checking - soldered U1930 upside down with jumper wires to confirm connections were good and same behavior. Only thing I can think of is there's a CPU issue - it's reading 10ohms to ground on the Phase 1 power rail. Going to pop this one on the unrepairable pile and sell the...
  19. C

    820-00165 Won't Turn On

    Checked U1930 again - replaced it again from another donor board and behavior is the same. With it out i'm getting ALL_SYS_PWRGD, PM_SLP_S3_L and all S0 voltages. With it there get a small pulse on ALL_SYS_PWRGD and then the board reverts and stays in S5 state. Board does absolutely nothing in...
  20. C

    820-00165 Won't Turn On

    Posted this in the wrong section by accident somehow so apologies for that! Reposting here: Got an 820-00165 here on the bench which is causing some confusion. Green Light is there which turns orange as normal, ppbus present 8.6V. Visual inspection revealed tiny amount of corrosion around...
Top