Search results

  1. brunomotter

    820-00928 No POST

    Got this board here for rework. It came here about 2 or 3 months ago for repair... On the occasion it had a short on 3v3 line that was preventing machine to turn on, also some corrosion around U7100, which I cleaned and replaced. Machine worked well for the next 2 or 3 months and yesterday it...
  2. brunomotter

    820-3787 Powers On No post

    Hello. Got this board here and it was not turning on, shorted PPBUS_G3H line, which I traced to bad U7330, which I replaced. Board worked perfectly yesterday after the replacement of that chip, I turned off the machine and left it sitting on the bench to finish assembling today. Today, when I...
  3. brunomotter

    820-3330 Shutting Off Intermittently

    Hello. Got this board here that shuts itself down when stressed. I thought initially it was bad battery because it was indeed bad. So I replaced it three times and same thing. Decided putting in an original battery that's working perfectly on another machine and problem persists, so I discarded...
  4. brunomotter

    820-00923 Only Works After SMC Reset

    Hello. I got this one here with very strange behaviour... Machine was not turning on. I reseted the SMC and machine worked perfectly for some days. Gave it back to costumer, after some days she brought it back to me with same problem. After replacing the battery machine worked for a whole week...
  5. brunomotter

    820-00928 Resetting USB-C

    Hello. Got this board from another store. It has already been poked/cleaned, so I don't have its history. Apparently no missing components. If I plug USB-C charger I get 5V on FB200 and F3000 does't matter if the USB-C cable is reversed or not. On the other 2 fuses I only get 5V if it's on an...
  6. brunomotter

    820-00840 Strange USB Problem

    Hello. This board came to me with no life. Shorted 3V3 line. Corrected that problem and the board started. Everything works fine except for USB/Thunderbolt/HDMI. I have a Satechi USB-C hub here which I use on all my personal Macs and use it to test all costumer's Mac, So I know it's working...
  7. brunomotter

    820-01521 Weird Video Loss Problem

    Hello. Got this one here with a strange problem. Internal video is lost a few seconds after the system loads. Just internal video is gone, backlight keeps on. On external monitor it works ok. If I start in safe mode everything works, except of course graphics drivers are not loaded, but internal...
  8. brunomotter

    820-00165 Partially In S0, Low PP5V_S4S3

    Hello. Got this board here with a strange issue. It partially turns on(some S0 state voltages are present). No fan spin. I have DDR voltage stable ate 1.2V, but PP5V_S4 is measuring low, at only 3.05V. Tried replacing TPS51980 and MOSFET, still same. Something is dragging 5V voltage down, some...
  9. brunomotter

    820-3536 Not Charging Battery

    Hello. This board came from another store and had been cleaned previously, so I don't know where original damage was. Board was liquid damaged but all traces of liquid had been erased by cleaning. Board turns on, works on battery and on charger, but does not charge battery. Magsafe light comes...
  10. brunomotter

    820-00165 Fan Spins, No POST

    Hello. Got this board here. Board is completely clean, no corrosion at all. Fan spins, I get 1v05 and 1.8V at CPU VCORE, no chime, no POST. Fan spins at max after some time, CPU gets warm. Tried reballing SMC, no luck, tried new BIOS, no luck, verified all SPI resistors and all read ok. No...
  11. brunomotter

    A1707 Backlight Flex Pinout

    Hello. I'm trying to fix an A1707 display assembly with bad backlight flex cable. I could only find some videos taking about A1708 which apparently is not the same. I peeled off protective varnish from the cable to expose the traces and ran jumpers from them., but the video I found on YouTube...
  12. brunomotter

    820-00928 Critical Software Update Needed

    Hello. Got this board here. It was liquid damaged 2 times about a year ago. I ultrasonic cleaned it and it worked again until about 3 months ago when keyboard died. I ordered an used original top case and installed and machine worked again for 2 months. Yesterday it came back here with this...
  13. brunomotter

    820-01061 BIOS

    Hello. Does anyone have this BIOS file here? I got a board from this iMac here that boots when it wants. Most times it get stuck on apple logo screen without loading bar under it, just apple logo, nothing else. Tried new SSD, new RAM, disconnected webcam, pulled off airport card, disconnected...
  14. brunomotter

    820-00923 No Internal Video

    Hello. Got this board here a couple of months ago that was not powering on. I fixed it and now it turns on and works with external display but no internal. I ordered a new LCD assembly to test, which works on another machine, but on this machine it does not work, just like original one. No video...
  15. brunomotter

    820-3437 Missing PM_SLP_S5_L

    Hello. Got this board here that had been messed on another shop. Missing PM_SLP_S5_L. There were some missing components and some bad resistors underneath CPU and R1905 was missing which I replaced. I get stable 8.56V on PPBUS and stable 3v3_S5 power rail but no PM_SLP_S5_L. Which signals...
  16. brunomotter

    820-00928 No POST

    Hello. Got this board here which had contact with shampoo(don't ask me how). It got soaked in shampoo by right USB-C ports and fluid got into the machine on upper part of the board near to CPU and GPU. U7230 was melted and I replaced it. There were a bunch of blown caps also which I replaced...
  17. brunomotter

    820-00239 No 20V

    Hello. Got this board here that has bee cleaned by another store because of liquid damage, so I don't really know where original damage was. After some inspection I found a blown coil, L4004 was gone and so was its pin 1 trace, so I rebuilt it with a wire, there's no shorts I could find. As...
  18. brunomotter

    820-00840 Got 20V Back, Still No Power

    Got this board here which was previously poked by another assistance. It got liquid damage(was cleaned before) and had no 20V. Replaced U3100 and SMC and got 20V back, but still no power. Compared side by side with another board from same model and cannot find any missing components. It does not...
  19. brunomotter

    [SOLVED] 820-3662 Vcore Present @1.72V No Chime

    Hello. Got this board here with VCORE stuck at 1.72V and not chiming. I thought it might be BIOS related so I flashed a new clean file, but still no luck, same results. I'm inspecting the board to see if I can find any obvious hints like corrosion or etc. Board has a few little green stuff but...
  20. brunomotter

    820-00840 20V 0 Amps

    Hello. Got this machine here with no power. Costumer says he tried to upgrade the SSD at home and after that the machine stopped working. He says he disconnected power from battery before putting on the new SSD. I tested the SSD on another machine and it works fine, so no shorted SSD. Removed...
Top