Search results

  1. F

    820-00840-A not starting

    Do you know what's required as input on U7800 for it to make PMIC_EN_P3V3S5 high ? PMIC_EN_P3V3S5 is PGD, so does that mean that it needs VSD to be good ? Or VSA, VSB, VSC, VSD all need to be good ? I assume VSx stands for Voltage Sense, and PGx stands for Power Good, so I'd expect PGD to turn...
  2. F

    820-00840-A not starting

    No, no pulse. It goes from floating state to 0V when I connect charger and that's it. And I do get the LDOs (PP3V1_RTC, PP3V3_LDO3V, PP1V25_VREF) with the new chip too. So, you suggest that I try again with another U7800 ?
  3. F

    820-00840-A not starting

    Both resistors are good, SMC_PM_G2_EN is high
  4. F

    820-00840-A not starting

    Hi, So I finally received my parts. U7800 replaced, but PMIC_EN_P3V3S5 is still low.
  5. F

    820-00840-A not starting

    Yeah that's what I thought too. I don't have any right now. I'll put this aside for now and report back later once I get some and replaced it. Thanks
  6. F

    820-00840-A not starting

    U7650 replaced. Still the same issue.
  7. F

    820-00840-A not starting

    Diode mode at 5V_S5 is 0.410V, so there's no short. Traces, solders and probe points look okay, and I have tested continuity for the few ones I had a small doubt, they are all good. I guess I'll try to replace the chip, just in case as you said, but I can't see how it can be the issue when the...
  8. F

    820-00840-A not starting

    Diode mode and resistance to ground: L7670: 0.407V 900Ohms L7690: 0.353V 780Ohms PPVCCGT: 0.0023V 4.6Ohms PPVCCCPU: 0.0043V 9Ohms PPVCCSA: 0.0066V 13.37Ohms PPVCCPCH: 0.0652V 130Ohms PPVCCIO: 0.0531V 106Ohms
  9. F

    820-00840-A not starting

    PPBUS is 13.02V And yeah I should maybe have started there, but no issue with the CD3215 stuff, of course. 20V from charger, which also implies 3v3_g3h is indeed present.
  10. F

    820-00840-A not starting

    Hi, I have this 820-00840-A board with liquid damage around U7650 and the backlight stuff also. I've narrowed it down to U7650 not creating PP5V_S5 and that's due to PMIC_EN_P3V3S5 missing. So, checking around PMIC, I could see that PP3V1_RTC is good, PP3V3_LDO3V is good, PP1V25_VREF is good...
  11. F

    820-00840-A 20V 44mA

    OK thanks. The liquid marks are not on U7800, just to make it clear. That area looks pristine. But yeah, my action plan right now will be to remove the few caps on the PP3V1_RTC line and check if the short goes away. If not, then I will reheat U7800, and if this still doesn't help, I will remove...
  12. F

    820-00840-A 20V 44mA

    Hi, I have this board that have signs of liquid spill. It won't turn on. CD3215 stuff works fine, I get 20V on the charger, so I have good PP3V3_G3H and PPBUS_G3H is present also. But then I get no other rails, no S5, S4 and probably nothing else either. The enable signal for those rails all...
  13. F

    Touchpad won't click

    I already went to trackpad settings, and the haptic option was turned on. But as per your suggestion, I just tried a PRAM reset, and yup, it did the trick. Thanks !
  14. F

    Touchpad won't click

    Hi, I'm not quite sure if this is a logic board issue, but since it may, I'm asking anyway. I got a 15-inch touchbar macbook pro with no keyboard and no touchpad. Knowing that keyboard goes into the touchpad, I immediately suspected the touchpad or its ribbon cable. The cable got replaced but...
  15. F

    820-00923-A not turning on - 20V 180mA on the charger

    Yes of course. All the measurements above were done with the board alone. The test with the ROM swap also.
  16. F

    820-00923-A not turning on - 20V 180mA on the charger

    So, I have borrowed a SPI ROM from another board that works. I know ME region is not compatible and so on, but I think it shouldn't matter and I should at least be able to boot with it. But it didn't work, still stuck at 180mA 20V, except that I noticed something which I didn't pay attention to...
  17. F

    A1708 820-00840 no PPBUS, no short

    Check piernov's youtube video for serial number change:
  18. F

    820-00923-A not turning on - 20V 180mA on the charger

    ALL_SYS_PWRGD and CPU_VR_EN_R are 3.3V PPVCCSA_S0_CPU is 1.05V
  19. F

    820-00923-A not turning on - 20V 180mA on the charger

    There's not much to say about history. This is in fact a laptop that comes from a friend of mine. It stopped working a while back, and he just stopped using it and got a new one. He eventually gave it to me so I could take a look, just in case I could revive it. He said it just stopped working...
  20. F

    820-00923-A not turning on - 20V 180mA on the charger

    Hi, I have this board from an A1706 which is not turning on. I do get 20V from the charger. Checking power rails and big coils on the board, I can see that I'm not getting PP5V_S4_T_USBC and PP5V_S4_X_USBC (enable signal is driven low by CD3215s) Also PPVCCEDRAM_S0_CPU is not present (created...
Top