820-00165-A Intermittent Trackpad

Have a 820-00165-A Board a customer brought in. Track pad will sometimes stop working about 5 minutes after full boot. If it gets past 5 minutes with it working it will stay on until a full restart. Only happens in the first 5 minutes within logging in

corrosion on the Track pad cable - replaced
Replaced track pad
Corrosion on R8155 & had low resistance - Cleaned & replaced, resistance measured good
Corrosion on C5120 - Cleaned, tested good.
Replaced U4810
Tried with 2 known good cables & track pads and they still go out sometimes around the 5 minute mark after boot.
Last edited:


Staff member
So the SPI mode is corectly maintained.

Do PRAM reset, test with USB macOS.
I do not expect software issue, but is better to discard.

Possibly accumulated crap underneath CPU...
Pram reset done with 3 chimes
Also tried with a new SSD with a fresh OS.
SMC is a little dirty underneath, could that be causing an issue? I can reball, if you think its worth a shot.