820-00165 Missing PM_SLP_S4_L

EsteTron

New member
MacBook Air came in for no power. No signs of liquid damage. All G3H and S5 rails present. Hooked up to DCPS and drawing 0.027Amps. Pulled board out and discovered the 25MHZ Clock Crystal Y1905 had exploded. Replaced Y1905 and Replaced u1900 RTC Clock since it was next to the clock crystal. Still missing PM_SLP_S4-L.

U1900 power:
Pin13: PP3v42_G3H = 3.44V
Pin2: PP3v3_s5 = 3.3v
Pin5: PP3V3_S5RS3RS0_SYSCLKGEN = 3.3v

Started looking around board and discovered another 24MHZ Crystal Y1915 (PCH Crystal) was starting to bulge gunk out of the side of it.Replaced it since it looked ready to die. Still now luck. Strange to see two clocks crystal dying.

After poking measurements around the board, the only measurement that really stood out to me PCH INTRUDER L reading 3.0v instead of 3.3v. When I measured PCH_INTRUDER_L for the first time, I got a fanspin for about 5 seconds, and then nothing. Is it possible that the PCH is pulling down voltage on PCH_INTRUDER_L? Just to make sure there was no junk hiding underneath PCH, I gave USC, but to no avail.

The part that is getting me is that it did briefly power on when I measured R1301 PCH_INTRUDER_L.
 

2informaticos

Administrator
Staff member
PCH_INTRUDER_L and PCH_INTVRMEN come from VRTC_G3H through high ohm resistors; usually 2.5-3V there.
Post basic signals for the power on sequence.
 

EsteTron

New member
Thank you for clarifying. Good to know

PPBUS G3H = 8.57v
PPBUS S5 HS COMPUTING ISNS = 8.57v
PPBUS S5 HS OTHER ISNS = 8.57v
PPDCIN G3H ISOL = 16.6v
PPDCIN G3H = 16.6v
PP3V42 G3H = 3.44v
PPVRTC G3H = 3.36v
PP5V S5 = 5v
PP5V S4RS3 = 0v
PP3V3 S5 = 3.36v
PP3V3 S4 = 0v
PP3V3 SUS = 3.36v
PP1V05_SUS = 1.05v
PM_RSMRST_L = 3.34v

PM BATLOW L = 3.36v
SMC_ONOFF_L = 3.44v
PM_DSW_PWRGD = 3.44v
PM_SLP_S5_L = 0v


PM_PWRBTN_L - 3.3v drops to 0v when R5115 is triggered.

I am hooking up my oscilloscope to measure clock readings
 

EsteTron

New member
PCH_CLK32K_RTCX1 = 32k

RTC_RESET_L = 3.36v
PCH_SRTCRST_L = 3.36v
PCH_INTVRMEN_L = 3.26v
PCH_DSWVRMEN = 3.26v
 

2informaticos

Administrator
Staff member
"PM_PWRBTN_L - 3.3v drops to 0v when R5115 is triggered."
Check for any pulse at all PM_SLP_Sx_L signals at same time.
 

EsteTron

New member
Okay.

PM_SLP_S5_L = 0v to 0v
PM_SLP_S4_L = 0v to 0v
PM_SLP_S3_L = 0v to 0v

Measured with both Multi meter and Oscilloscope.

I do get a weird voltage of 0.04v on PP3v3_S3 and 0.002v on PP3v3_s4.
 

EsteTron

New member
I had my suspicions.
PCH_DSWVRMEN reading 3.26v.

I'm calling this one dead. As always, thank you for your help.
 

2informaticos

Administrator
Staff member
You can try to heat PCH using good flux.
Just in case, to burn eventually crap accumulated undernearh...
 

EsteTron

New member
Before I gave up on this board, I reballed the SMC. No luck.

I then replaced the SMC with a donor board SMC and it now powers up to login screen. I'm testing it out to make sure everything works now.
 

EsteTron

New member
---SOLVED---
SMC failed, preventing PM_SLP_S4_L from being present. Replacing SMC resolved board issue. MacBook passes quality tests.

Thanks for your guidance on this one.
 
Top