820-00165 not booting fully, tried practically everything.

I am getting the strangest issues lately..
This MacBook Air 2017 is not booting; the loading bar takes a long time to fill up, and then it's stuck.
In verbose mode, it stops and waits for the iGPU apparently: keeps repeating this line every 60seconds:

busy timeout[0], (60s): 'IGPU'
busy timeout[1], (60s): 'IGPU'

I have tried with everything disconnected but known-good IO board and LCD.
Even tried only external screen.
Tried booting up several different known good flash drives with different OS-es: all same thing.

Tried cleaning ME region (with Medusa2)
Tried using 3 different 00165 BIOS files found all over the web (with or without cleaning the ME-region after writing it to the board).

Anyone have any ideas?

*EDIT: by the way, this board is absolutely clean.
ok, so that would basicaly tell me if the intel gpu is defective right?
what else could it be at this point..? I mean, i dont have a lot of time to start fiddling with ubuntu-drivers and such, and basically this is boiling down to either a bad cpu or integrated gpu right?
Just to let you know, i installed the intel graphics drivers for ubuntu, and everything works properly. so i am now assuming its a RAM issue? Weird that it works perfectly on Ubuntu..
My Google Fu is not good enough to find it on here so far, lots of dumps, but none clearly stated for 2017.
I can try getting a dump from a fixed 2017 MacBook Air from the queue, flash it on this one and clean ME?


Staff member
Yes, try that.
In fact, you can try the dump as is; just to see any difference about graphics.
And finally clean ME...
yeah figured as much..
i just did: flashed it on there without cleaning ME: no change in symptoms
Cleaned ME afterwards: Same difference..


Staff member
I don't know how Linux manages the graphics.
Can you try Windows and run some graphics stress, after driver installed?
I might not have time for this.. but what would that eventually tell me? I mean, if it's about to be the iGPU (CPU) than i'm calling it quits
Just an update for people reading this topic with similar issues

Got an email from the customer that the MacBook Air suddenly decided to boot up fully (he sent me a photo of the login screen)
This absolutely baffles me. have no clue what the issue was and will probably never know now.


New member
Thanks to Discord chat, piernov and ChrisB, we found a solution for this problem.
Q1920 is a Strap to temporarily disable ME region. I had 2 boards, 820-3437 and 820-00165, both with the same "boots till 100% than freezes" and "iGPU kext timeout" in Verbose mode.
3437 had some water damage on R9120 and R9121, 00165 was completely clean but after i repaired the first one i've found that there was a low resistance between GND and SPI_DESCRIPTOR_OVERRIDE_L lines.