820-00239 working without battery, burning D6902, U6903

aplas

New member
Hello,

820-00239 turns on on charger, no liquid damage, no history.

Board without battery, unplugged all connectors takes from charger:
20.03V
0.622A
Board with battery doesn't start, turns off if connected while working.

On thermal camera:
more heat on U6903 (replaced)
less on D6902 (replaced)
U3200 also burns hard

Power rails:
PPBUS_G3H - 13.12V
PPDCIN_G3H - 20.26V
PP5V_S5 - 5V
PP3V3_G3H - 3.333V
PP3V3_S5 - 3.363V

PPBUS_G3H is SHORTED to ground - 0.00 Om

thanks in advance.
 
Last edited:

2informaticos

Administrator
Staff member
"PPBUS_G3H - 13.12V (SHORTED - 0.00 Om)"
Are you joking???
I bet you checked for short with power applied; do NOT do that ever again.

If board works without battery, all power rails from PPBUS_G3H untill S0 state are good; including 3V3_G3H, so U6903 was good.
Try first known good battery.
Post PPBUS_G3H and 3V3_G3H voltage on battery only (NO charger connected).
 

aplas

New member
PPBUS_G3H for short checked with charger disconnected, red probe on ground, black on PPBUS_G3H with D6902 removed (sorry for inaccurate writing).
two different batteries same symptoms.
on battery:
PPBUS_G3H - 11.19V
3V3_G3H - 2.8V
 

2informaticos

Administrator
Staff member
"PPBUS_G3H - 13.12V (SHORTED - 0.00 Om)"
Then explain us how this possible...

Is REALLY IMPOSSIBLE to have 0 ohm on a power rail where you are able to get 13V!!!
If we cannot trust your measurments, we cannot help.

Apart of that, 3V3_G3H is not good on battery only.
Post all U6903 voltages for such case.
 

aplas

New member
I get 0Ohm to ground of PPBUS_G3H only right after disconnecting the power. If the board is left disconnected for a period of time it shows ~4kOhm.
See photos attached.

U6903 on charger:
1 P3V3G3H_VBST - 8,43V
2 PPVIN_G3H_P3V3G3H - 19,60V
3 P3V3G3H_LX - 3,52V
8 P3V3G3H_BIAS - 4,98V
9 P3V3G3H_FB - 0,978V
10 PM_EN_P3V3_G3H - 5,11V
 

Attachments

Last edited:

2informaticos

Administrator
Staff member
Always allow some time (10-20s) before diode mode readings, after power is removed.

I asked about U6903 voltage on battery only...
 

aplas

New member
U6903 on battery:
1 P3V3G3H_VBST - 8,5V
2 PPVIN_G3H_P3V3G3H - 10,61V
3 P3V3G3H_LX - 3,12V
8 P3V3G3H_BIAS - 4,97V
9 P3V3G3H_FB - 0,865V
10 PM_EN_P3V3_G3H - 5,10V
 

2informaticos

Administrator
Staff member
3V3_G3H is adjusted by R6910-13 divider.
One of resistors is out of range.
You can adjust one, to correct the problem.
In your case, need a bit lower R6911+13, or bit higher R6910+12.
 
Last edited:

aplas

New member
I was able to increase the voltage on PP3V3_G3H only to 2.955V by replacing R6910 to 200kohm resistor. If it resist more, very low voltage is generated and macbook doesn't start from charger.
Did I mention that computer turns itself off only after connecting J6951 flex cable. It's working with battery +/- connected.
 

2informaticos

Administrator
Staff member
You need to increase, not decrease 3V3_G3H; modify some resistor accordingly.

The board works perfectly without J6951 connected?
3V3_G3H is then normal voltage?
Try known good working battery.
 
Top