820-00426 KP during Boot


Hello. Got this board here. It gives a KP when booting. I booted into verbose and got it filmed to see where it was panicking. Apparently it's related to USB because on nanosecond line of verbose it says last loaded kext is IOUSBHostHIDDevice, which obviously is related to USB function. I tried verifying R4600/01 as I thought it could be some kind of current sensing issue and both read ok. I tried replacing U4600 and U4650 but still same. The board had some corrosion around R5250 and it was open, so I cleaned the area and replaced that. Also had some little corrosion on C8931, which I also cleaned and replaced. I'm stuck now. What else could I verify? Just to mention, I'm testing board alone in the desk right now, nothing connected to it except for external monitor via genuine thunderbolt to HDMI adapter, original 85W charger and a keyboard via USB and known good SSD with fresh MacOS installed. Same thing is happening.. KP during boot, related to USB
Last edited:


Staff member
"last loaded kext is IOUSBHostHIDDevice"
That is the last correctly loaded; problems appears in the next step, which could be GPU related, or something else.

Try starting in safe mode.
Also try Windows 10 Live USB.


No go with safe mode. Booting on windows live USB I get BSOD telling Stop Code: Driver IRQL No Less Or Equal
What failed: ACPI.sys


Suspecting bad RAM here... I got errors like these on a MacBook Air some time ago and it turned to be a bad RAM module. But the problem is this piece of crap has 32 RAM modules and it's a no go to replace them all!