820-00840 no power

Kyle93

Member
Arrived liquid damaged and pre cleaned by another shop. Stuck at 5V

PP3V3_G3H 3.3v

PPBUS_G3H 0.512V

Replaced both CD3215s and u7000 so far but no changes.

What should be checked next?
 

2informaticos

Administrator
Staff member
Do you know which areas affected by liquid?
Dificil to work after someone who left the repair not finished; possibly removed, or knocked off components.

Check LDO rails of CD3215 chips; voltage and diode mode to ground.
 
Last edited:

Kyle93

Member
PP1V8_UPC_XA_LDOD 1.8V 0.439

PP3V3_UPC_XA__LDO 3.3V 0.788

PP1V1_UPC_XA_LDO_BMC 0V 0.448

PP1V8_UPC_XA_LDOA 1.8V 0.448


PP1V8_UPC_XB_LDOA 1.8V 0.472

PP1V1_UPC_XB_LDO_BMC 0V 0.481

PP3V3_UPC_XB_LDO 3.3V 0.488

PP1V8_UPC_XB_LDOD 1.7V 0.471
 

2informaticos

Administrator
Staff member
Not easy to compare the values, posting in this manner.
However big diferencies appear; I hope all checked in the same way, red probe to ground.

You may have bad solders, or some bad chip.
1V1 LDO should appear on the chip corresponding to powered port.
 

Kyle93

Member
Yes all measurements were taken the same with red probe to ground.

measured again and 1v1 LDO remains at 0 no matter which powered port is used.

The other shop does not do component level repair, all they did was put it in ultrasonic before arriving here.

Anything else worth checking or is this a time waster?
 

2informaticos

Administrator
Staff member
"PP3V3_UPC_XA__LDO 3.3V 0.788"
This value is too high; bad solder, or bad chip.

USB-C redriver chip is not burnt?
 

2informaticos

Administrator
Staff member
Something more damaged by liquid on USB-C area.
Is also possible the other service removed some component intentionally.
 
Top