820-00840 Power button not working

Hello. I got a 820-00840 that was liquid damaged and both usb ports would give me 0v when connecting a charger. Had to replace both CD3215 chips and some caps and resistors around them to restore 20v and the board boots. Everything was working fine including the power button, so I sold the laptop to someone. 3 weeks later, it was returned to me because they could not get it to turn on. When I tested it, it would only turn on when you connect a charger to it. It does not automatically turn on when you open the lid or when you press the power button. Also, when the computer is on, I cannot turn it off using the power button at all. I have to do SMC reset to get it to turn off. I tested the board alone with just a charger connected and tried to trigger SMC_ONOFF_L, and PM_PWRBTN_L stays at 3.3v and the board does not turn off. I also tried to trigger PM_PWRBTN_L and SMC_ONOFF_L also stays at 3.3v and the board does not turn off. I am thinking there is an issue with the SMC but wanted to confirm first before changing it.


Staff member
Do you have 3V at SMC_ONOFF_L?
Did you triger using R50161/16 pads?
Disconnect KB, if SMC_ONOFF_L is not good.

You may need to reball SMC, if corrosion near it.
Yea I have 3.3v on SMC_ONOFF_L. I am not sure what resistors your talking about when you say "R50161/16", but I have my wire connected to pin 1 of R5170. I did not see any corrosion near the SMC but decided to pull the SMC and reball it anyway. After re-balling the SMC, I now only get 20v 0.03a for some reason. PP3V3_G3H is 3.3v and PPBUS_G3H is 13v, but all the other rails seem to be pulsing. I think I will try and replace the SMC with a new one tomorrow, unless you suggest checking something else.


Staff member
Sorry for misstyping, I meant R5015/16 pads.

Do you get pulse on VCORE too?
Check for pulse at PLT_RST_L too.

Inspect for moved parts in the reball process...
I do not see R5015/16 on this board.

I do not have a pulse on VCORE or PLT_RST_L. Seems like only the S5 rails and PP5V_S4 are pulsing now. PM_SLP_SUS_L pulses but PM_SLP_S5_L is 0v and no pulse. I checked for knocked off components near the SMC but do not see any.


Staff member
Sorry, I was looking wrong schematic; it happens sometime, if 15-20 pdf files charged on Acrobat reader at same time.
I meant SW9988/89...

You said board works, but cannot turn it off.
So PM_SLP_Sx_L signals MUST be high.
Confirm the actual state of your board...
The board was working, until I re-balled the SMC. After that, it would not turn on and I was getting pulses on a lot of rails. I took another look at the board and noticed a solder ball that bridged 2 capacitors together and bridged PP1V8_S0 with SPKRAMP_5V_3. I fixed this and now I am back where I started. The board boots again but the power button still does not work to turn the computer on/off. SMC_ONOFF_L, PM_PWRBTN_L and PLT_RST_L are all 3.3v. I soldered a wire to SMC_ONOFF_L and tried touching it to ground and holding for a few seconds, and the board stays on still, so it does not seem like an issue with the power button itself.
Ok so I removed the SMC again and checked continuity for SMC_ONOFF_L, and it was good. I then took another SMC from a donor board and put it on this board, but I still have the same issue. No change at all with another SMC so does not seem to be related to the SMC. Do you know what else could cause this issue?


Staff member
Some signals, or voltage missing to SMC.
Check SMC block at page 39 (SYM 2 OF 2).
Be sure to have 3V at all SMC_Txx signals.
Do you get SYSCLK_CLK12M_SMC?
All SMC_Txx signals are 3.3v and SYSCLK_CLK12M_SMC is 1.73v, which i'm not sure if that is correct. Here are the other voltages from SYM 2 of 2.

SMC_TCK - 3.3v
SMC_TMS - 3.3v
SMC_TDO - 3.3v
SMC_TDI - 3.3v
PP3V3_S5_SMC_VDDA - 3.3v
PP3V0_S5_AVREF_SMC - 3.0v
PP1V2_S5_SMC_VDDC - 1.2v
SMC_WAKE_L - 3.0v
SMC_CLK32K - 1.73v