820-00850-A - No Power - 20V 0.02A


Hi people !

I have a very clean board there, no liquid damage, that doesn't turn on. It seems it overheated around T2 Chip, on the back of it some resistors are kind of brownish (maybe it's just baked dust, IDK). I tried to restore T2 Chip but it is not enable to complete the process, always end with an error (tried with different host Mac, different OS, and official Apple cables).

I made some mesurements :
  • PPBUS : 12.7V
  • PP5V_G3S : 5.1V
  • PP3V3_G3H : 3.4V
  • PP1V8_G3S : 1.8V
  • PP1V2_S3 : 0V
  • PP0V6_S0_DDRVTT : 0V
After that I guessed the RAM was not supplied, so I check around his buck controller U8100. It is well supplied by 5V, but nothing comes out because it's not telling to (0V on pin 16 and 17). As these signals comes from the PMIC, I think it is the culprit, but I am not used to work on these models at the moment, so not really sure.

I'd like to know if I missed something and if there is some steps to check before I remove the PMIC and try to replace it.

Thank you for your time, Bye


Hi 2informaticos,

Here are the SSD voltages that I have :
  • PP2V7_NAND_SSD0 : 2.5V --> It seems I have a short there, 60ohms seems not right for this rail, I don't have a board to compare but on a A1706 board that is similar I have way more
  • PP1V8_SSD0 : 1.8V
  • PP0V9_SSD0 : 0.9V


Staff member
You cannot expect RAM voltage, if DFU can't be completed.
May have internal T2 problem, or SSD.

Sometime DFU can be completed after several days trying.
Apple did a "good job" with the f***g T2.


Well understood. I don't know how the DFU could suddenly be completed if I don't change anything on the board, is it kind of mystic shit ?

Joke besides, I ordered SSD voltage regulator (U9000), worth the try, I'll keep you tuned on this.


Staff member
You can use power on sequence from 01055, or 01598 boards; available on the forum.
U9000 requires more than simple enable signal.
It is controlled by T2.