820-01521 Weird issue

Hello everyone!

Have a weird issue on 2019 macbook air:

It does power on, however there is a question marc and while try to online restore the os – no success. It’s either stop on the downloading stage or during the installation. It once even got to the point where it ask you for the language but then it frizzed there. Tried DFU restore – goes well but does nor reboot after its done and shows padlock.

No liquid damage on the board, look clean and like no one played with it.

However I noticed that the led (D6959) on the board is not lighting up. After short troubleshoot I found that the led polarity are inversed I presume from factory?! Removed and placed it in the right direction, does light up now, however its dim and get only 2.3v and should be 2.7v if I am not mistaken. R6959 get 3.29v on PP3V3_G3H_RTC should be more as well I guess?

Have the voltage on all coils except the one for CPUGT witch I presume is normal since there is no load on gpu.


Battery is charging.
Does see usb key if plugget but obviously does not boot from it.

After disconecting and reconnecting the battery, does not power on. Need to plug the charger and after that will power on (from buttery or charger), not sure if thats normal.

Will appreciate any hints.

Thank you!
Last edited:


Staff member
First of all, welcome to the forum!

The board will not start with battery alone until press the power button.
Is normal to start by itself when you plug in the charger, w/o battery; or if wasn't properly turned off, w/ battery.
Machine should also turn on pressing any key from internal keyboard.

In the process repair, with board alone on the desk, use SWE010 pads, instead of power button.

If D6959 lights when charger is removed (battery present), press SW6955 untill LED goes off; don't touch anything on the board before.
Is better to completely disconnect the battery.

If DFU restore succeed, internal SSD should be good.
It should be visible in the other laptop, starting in Target Disk mode.

Now start on Internet Recovery, to reinstall original macOS.
Hi 2informaticos,
I would like to clarify that if i disconnect the battery and plug it back, it will not start no mather how long i will press power or keyboard button until i plug the charger. After i plug the charger it will act normally on power button press (except the question mark issue)

After that i tried the dfu restore, i am still not able to recover the machine with internet recovery
Edit: if i start it in a disk mode, the other mac shows "the disk you inserted was not readable by this computer".

Not sure if the issue is my cable. I try to use the same one that i was trying to use to do the DFU restore (usb a to usb c) since the second mac is an 2017 air and dont have usb c...

Also for general learning, what will happens if you disconnect the battery while D6959 lights when charger is removed? Maybe i did it because like i am saying the polarity of D6959 was inverted.

Also a side note: after the DFU is completed, the the mac does not restart on its own. Not sure if that metter how ever i do see a mac log and the loading bar on it for ~15 seconds before it shows padlock on the second mac

Edit: another thing i noticed. If i try to do the internet restore only on charger power (battery not plug in) the mouse is not responsible: the cursor moves super slow and whit a lag. I presume it shouldn be this way witch leed me to belive that there really is an issue with power delivery somewhere

Thank you!
Last edited:


Staff member
This board requires good battery to boot correctly.

Shouldn't happen something wrong if you disconnect the battery.
My advise was don't touch anything on the board while there is still power from battery; needs to discharge PPBUS_G3H rail first.

Get known good battery and try again Internet Recovery.
If original battery seems to charge, then give it time and try later.
Just saw the error message( did not pay attention at first since it was not in full screen size) in apple configurator when the lockpad is shows witch say "Apple Controller is not booted" and ask me to do a restore once more....
And after that it goes all over again: click restore -> apple logo on screen -> this error message instead of reboot.
Battery is good and charged by the way.

Bad T2 chip it is?


Staff member
Did you follow all the steps in tutorial?

Remove audio board and inspect it for corrosion, as audio flex too.
Try DFU again, without audio flex connected.
Audio board seems fine, would like to try with out it just in case but have a hard time finding the SWE010 pads :/ could you point around where they are please?

Edit: oh i found it, its on the other side of the board.... bravo apple, very smart

Still no luck with audio board off.. tried restore and revive with no success, still have the same error/warning about boot. Just in case updated the mac from where i am doing the restore/revive to big sur but it didnt help

T2 how ever get warm witch means its do work somehow?


Staff member
This machine has the BIOS embedded into T2 chip.
4MB SoC ROM chip can be modified, but more things need to do, in order to bypass the unlock.
Not a definitive solution however...
Any other things to check before i scrap the board?
Could it be related to usb c chip? Since the time it went all the way to selecting the language ut was just after i soldered some resistors around those chips (did not like how they was looking, a bit tilted)
Mesured some more voltages around the ssd and found that
PP2V7_NAND on the L9060 is at 2.48V
Wonder if that can explain the issue i am seeing?