820-02098 Water Damage, Charger Stuck 5V 0.2A Draw


Got an 820-02098 in which had liquid damage.

I've gone through the board under the microscope cleaning all areas I could find any issue with and i've run the board through the ultrasonic.

I ran through the power on sequence on the repair wiki and found that PPBUS_AON was shorted - i've identified the shorted cap and removed this now and now I get the 5V and 0.2A current draw on the power meter with just the board and the magsafe 3 connected. There is no light on the charger.

Checking the voltages I have
PP3v8_AON - 3.58V
PP5v_S2_MAIN - 5V
PP1V8_s1_CLVR_VDDH - 0v

Not sure where to go from here given I cannot find any schematics for this model!


I'll check out 02100 schematic see if I can guess anything based on that. I've tried DFU revive and it doesn't even get detected so that's a no go. Do we know which voltage rail is required to be working on these M1's to get the charger switching to 20v?


Further visual inspection reveals what looks like a broken component - maybe a diode? Attached a picture, the left side is connected to ground and the right side is not!WIN_20220722_11_06_33_Pro.jpg


Staff member
Possibly ESD protection diode; depends where is connected.
Try to find any common point on the free terminal with other components.


New member
Looks like CDZV6.8B if you search 02100 schematic.
Retract that- more like DZF687
Pic attached of marking, more on board like this.


Last edited: