820-2850 dim green light.

Chuck60

Member
Ok so I got this with quarter fan spin and it went straight to dim green light after a few minutes of diode measurements. With just the charger plugged in.
pp3v42 = 3.42
Ppbus_g3h = 0.3v
Diode mode ppbus_g3h=.489

R7020 pin1=2.4v [HR][/HR]R7021 pins 1 & 2 in ohms = 1.965 k ohms
R7022 pins 1 & 2 in ohms = 1.975 k ohms
R7022 between pins 1 & 2 =0.1
C7020 resistance on 1&2 =20ohms

Isl6295 (pins)27/28 20ohms
Isl6295 (pins)17/18 2.9ohms
Smc_reset_L =3.3v

Q7085 Pins 1-4=16.24v
Q7085 ppdcin_g3h_inrush =2.59v

Tried with battery g3h=12.5v at fuse f7040

thank you for your time
 

Chuck60

Member
U7000
1-chrg_agate=14v
2-chrg_dcin=16.7
3-chrg_acin=1.5mv
4-chrg_vfrq=8.5mv
5-chrg_iconp=8.4mv
6-chrg_cell=.8mv
7-chrg_vcomp=.6mv
8-chrg_vneg=370mv
9-chrg_Amon=.1mv
10-smbuss_smc_bsa_sda=3.38v
11-smbus_smc_bsa_scl=3.32v
12-pp3v42_g3h=3.42v
13-chrg_rst_L=3.1-3.9 fluctuating
14-smc_bc_acok=140mv
15-chrg_Bmon=46mv
16-chrg_bgate=77mv
17-chrg_cso_n=380mv
18-chrg_cso_p=380mv
19-pp5v1_chrg_vdd=6mv
20-pp5v1_chrg_vddp=6mv
21-chrg_Lgate=220mv
22-gnd
23-chrg_phase=380mv
24-chrg_Ugate=380mv
24-chrg_boot=500mv
25-chrg_sgate=16.4v
26-chrg_csi_n=.7mv
27-chrg_csi_p=.7mv

im sorry I just wanted to give all the info that I could :( thank you for your time and effort resolving this issue. I know the boards are old. I know they?re worth nothing but I?m taking this opportunity to add to my repair knowledge. Hopefully I will be able to return your kindness in the future thank you and the community:)
 

2informaticos

Administrator
Staff member
"3-chrg_acin=1.5mv"
There should be aprox 4V.

"19-pp5v1_chrg_vdd=6mv
20-pp5v1_chrg_vddp=6mv"
And 5V there.

So start checking diode mode (red probe at ground) on these points.
If nothing strange, then check R7010; could be open, because of corrosion.
 

Chuck60

Member
May I ask you something? When chrg_dcin=16v shouldn?t it output 5v on vdd ? Or am I confused about the operation of this circuit
 

2informaticos

Administrator
Staff member
No datasheet available for ISL6259.
But the other charger chips do not generate VDD untill ACIN is correct.
Is supposed to be valid for this one too...
 

Chuck60

Member
R7010 On pin 1 16.75v on pin 2-20mv
r7011 pin 1-20mv
i removed Both resistors
r7010=29.5k
r7011 =38ohms in circuit
r7011 =9.25 out of circuit
 

Chuck60

Member
I also did continuity test on a the v?as and all test good :/ I thought maybe the via where bad. Odd because I see no sign of water except near touch pad but even that was very little
 

Chuck60

Member
Oddly enough u7000 pin 3 .042v diode mode even when I remove both r7010/r7011 is this right? I have .549 on a 820-3115 board at the same point. The dot being pin 1
 

2informaticos

Administrator
Staff member
"r7011 =38ohms in circuit"
Remove C7011.
If works, you are lucky; not even need to change it.
If not, change ISL6259.
 

2informaticos

Administrator
Staff member
C7011 is not critical, let it out.
But need to replace R7011, seems to be bad.
Or maybe broken/corroded trace.
You should get aprox 4V there.
 

Chuck60

Member
Good morning soo I replaced the isl6529 before I saw your comment. The isl was shorted on pin 3 now I have 3.9 at acin. The light was dim even after the change and now checking around the mosfet I heard a ?click? and the MagSafe light turned a normal green and ppbus_g3h had 12.5v then died again. Bad solder joint ? Or MOSFET ?
 

2informaticos

Administrator
Staff member
"The isl was shorted on pin 3 now I have 3.9 at acin"
You had just a bad C7011.

Bad solders, or knocked off components around ISL6259 could now generated more damage on the board.

Did you solder good R7011???
 

Chuck60

Member
Yes I did solder it well. I have 4v at the voltage divider. I tried without c7011 it gave me 16v at pin3. I replaced it with another c7011. are you saying I switched isl 6529 for no good reason? :(
 

Chuck60

Member
Now after I changed isl6259 I have 4v at pin 3 I looked around all the components are still in their place I?ve double checked.
 
Top