820-2936 board ppbus 12.26v!!!

turbo

Member
got this board, water damaged , all cleaned now, ppbus im getting only 12.26v,

i changed isl , r7051 and r7052, q7030

isl 17/18 = 8 ohm
and pin 27/28= 20 ohm


any idea why ppbus is not 12.59v


computer turn on with adapter, not with battery
 

JohnB8812

New member
Dead SMC it sounds like. If you plug in the charger and the battery does it give you an "X" for the battery when it boots into the OS?
 

JohnB8812

New member
Yeah if the battery is plugged in and the OS is showing an X usually it's either the ISL is bad or the SMC which is more common
 

JohnB8812

New member
I'd do a diode mode reading on pin 2 of both R5280 and R5281 red probe ground black probe pin 2 and see if you get a short. I would guess you will which will be either the ISL or the SMC or (as Louis showed the other day) possibly (highly unlikely) one of the caps on the back bottom left of the board.
 

turbo

Member
I'd do a diode mode reading on pin 2 of both R5280 and R5281 red probe ground black probe pin 2 and see if you get a short. I would guess you will which will be either the ISL or the SMC or (as Louis showed the other day) possibly (highly unlikely) one of the caps on the back bottom left of the board.
which caps? iput new isl still same
 

JohnB8812

New member
PPBUS is 12.26 because the SMC is not running (if it was it would be 12.6). In the case of liquid you want to look at the data lines on R5280 and R5281. If either measurement is short, then one of the data lines between the the SMC and the battery are no bueno because either the SMC is dead or has crap under it, the ISL you replaced is bad, or one of the caps attached to those data lines on the back of the board is shorted or bad which is really rare
 

G.Beard

New member
Dead SMC it sounds like. If you plug in the charger and the battery does it give you an "X" for the battery when it boots into the OS?
Or the I2C data / clock line is broken, or the battery is fucked. Personally I would bleep out the cock and data lines from 6259 to SMC and then slap a new 6259 on there and test with a good battery WAAAAY before looking at the SMC!!
 

turbo

Member
YES i tried original apple battery 2 know good one, , isl is good too , SMC some how not knowing that battery is connected , what to do!!!!
 

JohnB8812

New member
Ok then yes this is a battery recognition issue. If the ISL is good, then it's going to be related to one of the data lines being messed up. We need diode mode readings for R5280 and R5281 to figure out what could be wrong here.
 

larossmann

Administrator
Staff member
Give a diode mode reading for pin 2 of R5281 and R5280 with no power going through. Put the red probe on ground, black probe on pin 2 of R5281, and provide measurement in diode mode. Do the same with pin 2 of R5280.

PPBUS_G3H is 12.23v instead of 12.56v because the SMC is not communicating with the ISL6259 as it is supposed to. The SMC uses this same data line to communicate with the battery, so if this does not work then it will not recognize the battery either.

Look at C6952 and C6953 as well and tell me what they look like.
 
Top