820-3115-b ppbus_g3h 12.3v

mdc2018

New member
820-3115-B
not charging battery



​​​​​​Irregular readings I noticed:

​​​​​​PPBUS_G3H = 12.3V

SDA Battery Data Line = 3.2V

SMC Reset is Good

Is this a bad SMC?
 

JohnB8812

New member
Either bad ISL or bad SMC. You can start by removing edge bonding on SMC and giving it some flux and heat. 12.3 makes me think it’s possible the SMC isn’t dead yet has crap under it
 

mdc2018

New member
Okay I will try this on the SMC, tried a couple new ISL already.

Before we confirm SMC anything else I can try?
​​​​​
 

2informaticos

Administrator
Staff member
SCL/SDA lines on diode mode cannot give more than 1% difference, respect to ground.
If not, remove D6950 and check again.
BIL connector is supposed to be disconnected, of course.
Next step, if needed, remove U7000 and test again.
If still get difference with only SMC on that bus, gues what?
BTW, try first to reflow it with good flux; could be only crap under SMC...
 

2informaticos

Administrator
Staff member
.5 is completely irrelevant...
As I already told you lees than 5% difference.
Fot example, .485/.500 is too much difference.
Try to post correct information.
 

2informaticos

Administrator
Staff member
Is Q7055 bad in your case?

"lees than 5% difference"
My fault; should be 1%, like in the previous post...
 

mdc2018

New member
How can I effectively test if Q7055 is bad? It gets the 12.3V in but does not go out, pin 4 stuck at 12.3V . Pin 5 has a dropping voltage.. Starts around 4v continually lowers, rate of decrease slows as it gets lower.
 

2informaticos

Administrator
Staff member
CHGR_BGATE must go low to enable battery charging.
Pin 5 of Q7055 should maintain the battery voltage.
Did you try known good battery?
Check if R6950 is OK.
 
Last edited:

2informaticos

Administrator
Staff member
Do you get the battery voltage at Q7055 pin 5?
Test the battery voltage on other board, then check back in this one...
 
Top