820-3115 no steady green light

Fizzl92

New member
Hello,
i am working on a 820-3115 with waterdamage. I actually fixed this one but it came back for the second time now with no green light. I had to run wires around U7000 and as it came back the first time i replaced u7000 and it worked again. Now i replaced U7000 again and that fixed the green light. But now PPBUS is missing (no short). I followed this path and came to Q7085. It has 16,2-16,8V at pin 1-3 (pulsing up and down) and only aroung 7-9V at pin 5. I guess it has to do with the pulsing voltage. I checked Q7085 and when plugged in it beeps (pin 1 to pin 5) At pin 2 of R7021 i can only measure 4,7V. I checked current sensing already but the resistances are fine (3Ohm and 23Ohm). Now i don´t know where to search next and what to do to prevent it from coming back...
Thanks for any help
 

Attachments

dukefawks

Administrator
Well it could be anything around U7000. Crappy soldering/dead chip/another corroded trace. No way to tell, you need to check everything and all traces, possible replace U7000 again.
 

Fizzl92

New member
Thank you. You were right. I replaced the ISL again (and after that again because it was shorting a dataline for the battery so the machine could not recognize the battery) and now it works. Any idea what could kill the ISL twice? I really want to prevent it from coming back...
 

Fizzl92

New member
While testing it died again and now i can´t get it back to live. CHGR_DCIN is going up and down from 15.X to 16.X V so the ISL can not work right? I already replaced the ISL again (twice to be sure) and also Q7080 and Q7085 but no change. Still just a dimm green light (i can see it pulsing a little brighter and darker when CHGR_DCIN is going up and down) and no sign of life. Is there anything i can do with this one?
 

dukefawks

Administrator
The first thing to check when no green light is of course 3V42, ACOK. But with CHGR_DCIN fluctuating there is probably a problem with the 6259 or Q7030/35. Check traces to the gate of these FETs too.
 

Fizzl92

New member
i checked the traces to the gate and they beep to the isl on the other side of the board. I also exchanged Q7030 and Q7035 and the ISL again but still the same. Dimm green light but Voltage on CHGR_DCIN fluctuating between 14.X and 15.X V now.
 

dukefawks

Administrator
I have no idea, it must be something around U7000, corroded trace/resistor/cap. No way I can tell you which one. This board should however work from a charged battery, check that too.
 

Fizzl92

New member
It is not working with a charged battery, PPBUS_G3H is 12.0V from battery and the battery indicator is also not working
 

dukefawks

Administrator
Battery indicator not working would suggest an issue on the data lines. They go to U7000 and the SMC, take your pick.
 

Fizzl92

New member
After replacing U7000 at least ten times id say time for a shot on the SMC... But the SMC can not cause CHGR_DCIN fluctuating right? R5280 and R5281 have 3,42V on both sides. Can this be when the SMD is dead?
 

dukefawks

Administrator
Voltage on the data lines can indicate a problem, but 3.42V being there does not rule out a dead SMC. Check the SCL line with a scope, you should see pulses.
 

Fizzl92

New member
Unfortunately i don´t have a scope jet so i have to try a new SMC. Now the green light is back (pulsing a bit) and PPBUS_G3H is also there but fluctuation between 12.6 and 12.9V. But CHGR_DCIN is still fluctuating between 15.X and 16.X V. I also noticed the fan wants to spin (actually its not moving but i can barely see it moving a little bit every time the voltages are goung up) Could the SMC kill the ISL in general/so often?
 
Top