820-3115 Quarter Fan

brunomotter

Member
Hello. This board came to me about 2 months ago dead. Shorted PPBUS_G3H. I fixed the short and the board worked for the next 1 or 2 months. Last week costumer brought it back with a strange symptom. If the machine is left off for about 10 minutes it starts one time. No matter if you leave it on for 5 seconds or 1 hour, if you shut it down it won't power again immediately. If I leave it sitting on the bench for some minutes it turns on again for one time and does the same. When it stops working I have quarter fan spin. All S0 coils pulse during the quarter fan except the CPU VCORE ones. Any ideas?
 

brunomotter

Member
PCH_SRTCRST_L - 3.34V
PPVOUT_G3_PCH_DCPRTC - 1.552V

This while quarter fanning. I don't know if these are the voltages you asked. Correct me if I'm wrong.
 

2informaticos

Administrator
Staff member
Sorry, if there is quarter fan spin, then RTC signals should be good.

ALL_SYS_PWRGD pulsing?
Inspect R7402/03 and solders around U7400.
 

brunomotter

Member
Resistors are good. Re-flower U7400 pressing it down with tweezers and touched pins with iron to make sure it's not solder problem. Same thing. First time I plug in the board it turns on. If I unplug and plug it in right after it won't turn on, just quarter fan. If I let it sitting on the bench for some minutes it'll turn on again once and do the same thing. ALL_SYS_PWRGD pulses when quarter fan.
 

2informaticos

Administrator
Staff member
Check for corrosion near U5750 and U5010.
Change C5001, just in case.

Same thing happens if you keep keyboard disconnected?
 

brunomotter

Member
Replaced the cap, no corrosion around both chips. Same results... I'm testing the board on the bench, no peripherals attached.
 

2informaticos

Administrator
Staff member
Quarter fan spin and S0 present only that moment (I suppose)?
R7402/03 both good?

SMC from donor board, same model?
Be sure to have good solders.
 

brunomotter

Member
No! I plug in the charger, fan tries to spin but does not. S0 rails stay present until I disconnect charger. SMC from same model. R7402 and 03 reading accurately.
 

brunomotter

Member
Yes, it's REALLY weird! But that's what's happening... It dos not get even a quarter fan, just as if the fan would start but does not. Just a little "unparking"(know this word does not exist, but still...). And all rails except VCOR remain ON.
 
Top