820-3332 Graphics issue rabbithole


New member
I've got here a board that cannot boot. It turns on, shows the Apple (with loaded SSD), but then it freezes a moment before it should display the login screen. Sometimes the Apple has slight red lines on that moment. Then it restarts and do it again in a loop. I believe it's the moment when it should switch on internal graphics.

It's a motherboard issue, I've got many other screens, SSDs and all the other parts for this laptop, I even tried to put the motherboard in different body from another A1398 2012, but it's still the same. USB drive with ASD or macOS will not boot either. Internet recovery also not possible. No changes after SMC/PRAM reset or in SMC bypass mode.

I found more threads about similar issues, but never found a solution. The board was a bit dusty, but no spills or oxidation and no signs of previous work - owner told me that one day it just did not boot. Whole machine looks good, no dings, adapter is genuine MS2 85W.

I already changed all four VRAMs, GPU, GMUX U9100, U9150, U9200, U9210, U8900, I tried BIOS chip from different 820-3332, even tried flash with clean ME, but it's still all the same.

Is it possible that something went wrong with Intel graphics and changing the CPU will solve this? I already spent a lot of time and money on this board, but it's so tempting to not give up when it "almost" works...

Edit: I forgot to add some measurements:

PPBUS_G3H 12.56V
P3V42_G3H 3.41V


PP1V05_S0 1.05V
PP1V5_S0 1.52V
PP1V8_S0 1.81V
PP3V3_S0 3.34V
PP3V3_S3 3.34V
PP3V3_S5 3.34V
PP5V_S0 5.02V
PP5V_S3 5.03V
PP5V_S4 5.03V
PP5V_S5 5.03V

PPVCORE_S0_AXG 0.84V only during chime, otherwise 0V
PP1V5R1V35_S0GPU 1.5V before chime, 1.35V after chime
PP3V3_S0GPU 3.32V
Last edited:


Staff member
at that point you have changed just about everything, I don't see why the CPU wouldn't be next on the list. can it boot into a windows OS or ubuntu?


New member
No Title

Yes, it boots into ubuntu and even W10, but there are visible lines on grey color (look at the photo). In W10 there's only one GPU in device manager and that's dev_0fd5 which is GT650 I believe (driver is missing, so it's using some Microsoft generic one). So those artifacts are not made by Intel graphics? But those artifacts are exactly the same as on the Apple logo before every crash and they are present since I first opened this machine... and I really changed GPU + VRAMs for a new ones and artifacts did not change at all after that. They are on external screen also, even with internal disconnected.