820-3332 won?t load

Kyle93

Member
Have a 820-3332 that won?t show anything except backlight on internal lcd. On external you get apple logo but only loads quarter way before freezing with line above apple logo. See picture

What to check first?
 

Attachments

JohnB8812

New member
Also question, does this one look like it?s been worked on? I had one just like this as well, and I?m hoping you?re not getting boards that I?ve already deemed junk... lol
 

Kyle93

Member
Reflowing U8900 had no change.

Yes this came from a store. They said it came from another repair facility stating they replaced several components and claimed it was a GPU issue. Would replacing GPU resolve the issue or is it best to give machine back as a no fix?

Serial number C02HWC2HDKQ1
 

JohnB8812

New member
Hahahaha that?s the one I worked on! I had a post on this just last week on this forum!!! So here?s what I?ve replaced on it so far: U8900, the edP MUX, the big GMUX, the LCD connector, all of the filters on the backside by the DC-in connector. Original problem was no external nor internal video. Resoldered U8900 got 5 volts to the LCD (had zero before). Had short on BKLT found short near the transistors. Got BKLT but no image (weird) and restored external (or so I thought). Replaced U8900, the LCD connector and the filters first to rule that out. Same thing. Replaced both MUXs same thing so said fuck it. If you notice, you get BKLT as soon as the fan spins then the screen flashes and it chimes. I suspect either bad GPU, bad VRAM or an internal crack in the board somewhere. If you can replace the GPU itself, give it a try. After that and VRAM, I would say junk at that point. You should def tell that store NOT to send you junk tho lol
 
Top