820-3435 no green light, PPV5 and PPV3 missing

Dmitry

New member
Hi everyone, I just want to confirm that I have a case of bad smc? as I mentioned before I am in a remote area so it is a big deal to order parts. So I hoping someone can confirm that I have smc issue.

820-3235 - no green light not water damaged. doesnt turn on.
PPBUS_G3H - present
PP3V42_G3H - ok
PP5V_S5 - missing
PP3V3_S5 - missing
I checked U7501 and figure SMC_PM_G2_EN is missing, I checked resistance to ground on SMC_PM_G2_EN and it is fine(not broken)
 

Dmitry

New member
SMC_RESET_L - 0.4v - it should L? or I look at it a wrong way?
PPBUS_G3H - 8.2v
 
Last edited:

larossmann

Administrator
Staff member
0.4v points to bad SMC more than SMC_RESET_L missing because of the pullup resistor or U5110 being bad. How does U5110 area look?
 

Dmitry

New member
SMC_RESET should be high, there is your problem.
louise, U5110 look fine, there is no signs of any kind water damage. R5100 is fine.

I replaced U5510 (SN0903049) with SN0903048 from 820-3209, pin out and signals look the the same on the chip. I got 3.4 on SMC_RESET

I got green/yellow light. Macbook turns on BUT i have new issue, not sure were to start to diagnose it. It turns off randomly 1-4 min is max. Light on the chargers switches green when it turns off and then switches back to yellow. I can easily turn it on after it turns off. It looks like it simply loosing power. It does the same thing with or without battery.
 

dukefawks

Administrator
If the light turns green the SMC probably had a reset. So the problem was not solved, something got heated up and now SMC_RESET is intermittently being pulled low.
SMC_RESET does go to the trackpad, so check cable/connector/trackpad for corrosion. Disconnect trackpad cable and see if board stays on, fan will run on full and system will run slow of course.
 

Dmitry

New member
If the light turns green the SMC probably had a reset. So the problem was not solved, something got heated up and now SMC_RESET is intermittently being pulled low.
SMC_RESET does go to the trackpad, so check cable/connector/trackpad for corrosion. Disconnect trackpad cable and see if board stays on, fan will run on full and system will run slow of course.
Thanks, unfortunately disconnecting track pad flex doesnt make any difference, as well as there no corrosion that I could find. Can it be smc it self since U5110 close to it and could get hot
 

Dmitry

New member
I had 3.4v on SMC_RESET after U5110 replacement. After reballing SMC I get the same thing. Macbook turns on and shots down every 2-4 min. Light turns green when it turns off. One time it stock on green light and will not turn on SMC_reset was 3.4v no flexes connected to the board. In what causes green lights causes the board not to response to power button and auto turn on? Do you think SMC bad?
 

dukefawks

Administrator
SMC is fine. Green light can only happen when SMC resets or power to SMC is lost. So either SMC_RESET is pulled low or 3V42 shuts down. Check J6100 for corrosion? Remove it anyway.
 

Dmitry

New member
SMC is fine. Green light can only happen when SMC resets or power to SMC is lost. So either SMC_RESET is pulled low or 3V42 shuts down. Check J6100 for corrosion? Remove it anyway.
J6100 doesnt have any visual problems with it, I removed it nevertheless. Macbook works fine since, I run it now for 3 hours, doesnt have any issue, I am hesitant , but it works, I will keep testing.
Thanks Duke!
 
Top