820-3476 no boot when cover is placed

Repairable

Active member
HellO all.

Got a MacBook today.
That does not boot.
When i remover the cover and plugde the charger it booted
When i then press the d key on boot it passed all test
When i replace the cover and i restart the systeem it does not boot
Green light stays on when cover is in place
When i then remove the cover i have to unplug the battery and when i then (without battery plugged) it boots

It only happens whit cover,

Btw no Asd for this model ?
 

Crizz

Member
I had a similar problem with a machine where the spongy thing on the lvds connector was shorting all the pins when the cover was on.
After placing capton tape around the connector it worked!
 

Repairable

Active member
I had a similar problem with a machine where the spongy thing on the lvds connector was shorting all the pins when the cover was on.
After placing capton tape around the connector it worked!
Seems it is something else fully taped it
It boots a few times. But when battery is full it does not boot. Atleast thats what just happend ?
 

Repairable

Active member
Unplugged battery
Replaced cover.
Charger Goes in green light , 3 sec later orange light (battery stil unplugged)
Replaged charger more then 15 times everytime it boots

When battery connected, when it does not boot the charger light stays green, it boots when it turned orange

Dang i am gonne cry. Now it booted when charger was green charger was green and battery is 100%
 
Last edited:

dukefawks

Administrator
Is the battery functional when connected and the cover is not in place? It seems like the cover is shorting something out in the battery or it is a very dead battery.
It is normal for the light to still turn orange even when the battery is disconnected.
 

Repairable

Active member
yes when i had the charger unplugged and the cover removed the systeem kept running
even if i have the charger unplugged with cover pressent the system runs.
its really messing whit me

hmmm let me check battery, i dont have a spare one for this model.....i can only measure
 

Repairable

Active member
hmmm this just made me very humble and feeling very stupid.

thanks Duke huge thanks, i was so focused on the cover, that no where in my mind the battery was something i was thinking about.

"somewhat" embarresed atm the battery gave a 2,2 volts, it just had inuf the work for a few short moments so that the test function was done (pressing D key when booting that small test)


:eek::eek::eek::eek:

if it is running, and the battery is bad, can it make the systeem shutdown?
 
Last edited:
Top