820-3662-a automatically restart while i connected battery

2informaticos

Administrator
Staff member
You didn't specify if machine starts with battery alone (no charger).
Also good to know exact PPBUS_G3H voltage without battery (only charger connected).
Just in case, change Q7155.
 

tech

Member
With battery,irrespective of adpter, machine is restarting in loop,
the machine works fine on adapter without battery ( no restarting issue)

PPBUS_G3H 12.40v

Q7155 after changing same condition
 

2informaticos

Administrator
Staff member
"PPBUS_G3H 12.40v"
Did you check it at F7140/41?
Be aware, pin 1 of L7130 is not proper test point for PPBUS_G3H.

Check resistance (ohm scale) between pins 17/18 and 27/28 of U7100.
Also check voltage and diode mode to ground on SCL/SDA lines of battery bus.
 

tech

Member
yes F7140/41 good fuse

L7130 pin 2 volt-12.60v ( PPBUS_G3H )

U7100 pin 17/18 -3.4ohms

pin 27/28 -21.6ohms
 

2informaticos

Administrator
Staff member
12.6V is the expected voltage; you might got 12.4V at incorrect test point.
That's the reason of above explanation.

Post SMC_CHGR_BMON_ISENSE and SMC_DCIN_ISENSE levels, with both charger and battery connected.
Also check if machine stays on (no restart) in SMC bypass mode.

Did you test with known good battery?
Keep in mind "new" (chinese, or not), is not the same as known good!
 

2informaticos

Administrator
Staff member
Google???

Just in case...
 
Last edited:

2informaticos

Administrator
Staff member
Could be; not al machines have the same behavior however.
MacOS adjusts CPU clock and other power related performances, depending on battery presence.

We have reported on the forum tons of weird issues caused by incorrect battery.
So known good battery is a "must test".
 
Top