A1989 820-00850 - slow and full fan speed

dudipupan

Member
Hey,

Im struggling with another 820-00850 Board.
The MBP ia very slow. I received it with formatted SSD and I can't even install MacOS. It stucks on status "Less than one minute..." with progress Bar at ~25%
I already tested the Board in a Known working case - without luck. I recognized that the LVDS connector Was damaged. Replace the LVDS cable and the screen Connector of the display Assembly.
Now i'm out of Ideas what could cause this Problem 😕

Thank you and best regards
DudiPupan
 

dudipupan

Member
And the Macbook doesn't Start from Known good battery. But stays on if I Start it with charger and unplugged the charger afterwards
 

dudipupan

Member
I just sah that i was not the first one working on this Board. Looks like a water damage on the lvds connector. There is a coil missing (L8504) für PP5V_G3S_ALSCAM. Could this be the reason? Missing connection to the cam sensor?
 

dudipupan

Member
I just replaced the coil but same Problem. Tried also with disconnected Webcam... also without success. Currently I don't have a second woking T2 macbook for DFU restore 🤔😔
 

2informaticos

Administrator
Staff member
You don't need another T2 machine.
Run Apple Configurator 2 in other machine, which supports it.

Read here, for more info...
 

2informaticos

Administrator
Staff member
Did you try Internet recovery mode?

Possibly some data lines of T2 affected.
I saw something similar into 01521 board, damaged by liquid spill on audio board.
However, in that case couldn't even complete DFU...
 

dudipupan

Member
When trying to connect to a WIFI nerwork it stucks connection to it. If I use my Wifi Hotspot without WPS key it connects but breaks with an error while loading (displaying 1h 40 min as remaining time)
The MacBook seemed to work when I bought it (very slow but macOs was installed on the pictures of the offer).
 

dudipupan

Member
I think it might be the battery flex connector on the Logicboard... I did some continuity measurements and recognised most of the pads arent connected to the battery board. I will try to replace the connector tomorrow... This will be fun :-D I hate soldering those connectors...
 
Top