A1990 820-01814-01 No power (5V on ampmetter)

Hello, I have an A1990 that has no power. It only pulls 5V from charger.
On PP20V_USBC_XA_VBUS it only has 5V on F3000.
Can you help me?
 

2informaticos

Administrator
Staff member
Do you get 5V on all ports?
PPBUS_G3H is first voltage to get on T2 boards.
Check for short, or low value in diode mode.
 

2informaticos

Administrator
Staff member
Unfortunatelly, you didn't bother to specify which coils exactly.
Supposing the problem is on VCORE, remove U7410/20/30 one by one and check when the short disappears from PPBUS_G3H.
If still there, your problem is on iGPU coils; do the same there, if needed.
 
Sorry, it was not my intention to ignore your request
They are all the same:
LA430 = 1.37 ohm on PPVCORE_S0_GFX_PH3
LA640 = 1.35 ohm on PPVCORE_S0_GFX_PH2
LA650 = 1.36 ohm on PPVCORE_S0_GFX_PH1


L7231 = 2 ohm
L7221 = 2 ohm
L7211 = 2 ohm
L7330 = 24 ohm
L7420 = 5.5 ohm
L7410 = 5.5 ohm
LA300 = 174 ohm
LA350 = 28 ohm

Shel i remove U7410/20/30 ?
 

2informaticos

Administrator
Staff member
NO, as you have 5 ohm there.
U7210/20/30 must be checked.

My mistake in previous post; typed 74 instead of 72...
 

2informaticos

Administrator
Staff member
You said to have short on PPBUS_G3H.
Did you apply power on the board again in this condition???

I said to remove chips one by one, and check every time resistance to ground at PPBUS_G3H.
 

2informaticos

Administrator
Staff member
"LA430 = 1.37 ohm on PPVCORE_S0_GFX_PH3
LA640 = 1.35 ohm on PPVCORE_S0_GFX_PH2
LA650 = 1.36 ohm on PPVCORE_S0_GFX_PH1"
Check associated chips...
 
Hi, i´m a newbie on this, so i ask you to be patient with me :)
I've removed the QA340, but still have 1.22 ohm on LA340, and don't know to go from here.
i suppose that, if all 3 phases are shorted, they should have a common point between all of them that is causing the short, but i can't find it. Am i rigth?
 
Top