iMac 27" A1419 820-00134-A not turning on

ielectron

New member
Hi,
Do anyone have a schematic diagram for this iMac? main board 820-00134-A.
We got one with is dead checked voltage from power supply 12V ok 3.3V ok, no probe lights on board, 3,3V on power button ok.
what I found was faulty bios battery and second is short on 12 V line on this partly removed coil I tried find short but nothing came up as heating up part.
Any ideas ?
Thanks
 

Attachments

2informaticos

Administrator
Staff member
Try to find similar schematic from other iMac; this one is not available yet.
You can work using datasheet of the ICs from the board, or schematics which use them too.

Which is the exact value of that short?
Are you sure it is 12V rail?
Check ohm mode between that rail and all big coils.
If any gives close to 000, then remove corresponding high-side MOSFET and check again that rail to ground.
 

ielectron

New member
thanks for response. multimeter shows me 002 , on MOSFET with I disconnect from circuit by removing one coil side is 12V when coil connected full short and 0V. I was tried to find some mosfet connected to this rail found one, removed and is same. I will try find schematic with will be similar.
 

2informaticos

Administrator
Staff member
That is CPU core coil and low value to ground could be normal.
If you get short on 12V rail when that coil is soldered, means its MOSFET is shorted.
Remove the MOSFET connected on that coil and check again 12V rail for short.
 

2informaticos

Administrator
Staff member
You didn't even mark the rail in the photo.
You assumed to be 12V rail in base of which reason?
That coil is not placed on any 12V rail...
Did you find any schematic close enough to your board?
 
Top