[SOLVED]820-3115-B no PP3v3_S5 or PP5v_S5


Liquid damage near rear vent SMC etc. Came from another repair place that seems to have told a blind man to brush the board with his old toothbrush.

Stuck it through the UC, plugged it in and get a green light but no spin.

PP3V3_S5 is 0.0v with a 0.107v diode mode
PP5v_s5 is 0.995v with 0.007v on diode mode
U7200 pin 16 is 12.58v

Replaced U7200 & C7273 but no change.


PPBUS is ok if you have 12.58 on pin 16, the problem here is the short on PP5V_S5, inject voltage on this line and check what gets hot...


Stuck 5v in it and U5805 got hot. Swapped that along with everything around it and I get 3.3 and 5v now. Fan still spins but no VCORE yet :(


Im not getting PP5V_S4_P18v5s5 out of pin 1 on U5805. Am I supposed to get 18.5 out on pin 1 & 8 on this or do I only get that when the trackpad is connected?


Staff member
Forget about trackpad and U5805.
You only need an USB mouse to see if board starts.
Do you get voltage on all secondary coils, apart of CPU ones?
ALL_SYS_PWRGD goes high?


Forgive my ignorance but I'm not sure what secondary coils are. Here are some voltages from what I guess is what you need.

As to a USB mouse.. it lights up.

Q7950 gives 3.3v on All_sys_pwrgd

I'm getting full fan now also.

L7520 0v
L7510 0v
L7550 0v

L7330 1.5v
L7260 5.3v
L7220 3.4v
L7100 0.8v
L7630 1.1v


Duke.. Pin 16, 17 on U7200 looked like they had crap on them before I cleaned the board and swapped it so it possibly sent 12v into the 5v line there.


Just found R7402 (CPUIMVP_TONA) was 1.5mohm rather than 150k so swapped that out. Swapped U7400 also. Still no change though


U1800 is warm but still no vcore.

On U2650, I get:

Pin 1 = 3.3v
Pin 2 = 0.04v
Pin 3 = GND
Pin 4 = 0v
Pin 5 = 3.3v


U7400 I get:

Pin 46, 29, 19 = 5.1v
Pin 1 = 12.29v
Pin 48 = 12.34v
Pin 43 = 0v
Pin 11 = 5.1v
Pin 6 = 0v
Pin 8 = 0v
Pin 21,22,23 = 1v

I'm stuck


Hi Duke, thanks for replying. Yeah 181k and 150k now..

12.57v getting to them and 12.29v for U7400 side of R7403 with the same at pin 1 of U7400
12.35v for U7400 side of R7402 with 12.34 getting to pin 48 on U7400.

I'm getting no output on pin 24. I'm assuming there should be a voltage going from pin 24 on U7400 to U2650 to tell it CPUIMVP is good.

It seems like I have voltages in where I should on U7400 so I'm not sure why it isn't outputting CPUIMVP. Unless Pin 22 (ALERT) tells it to turn off when a voltage is present on that pin. (currently 1.1v)
I can't find a pdf for MAX15119GTM


Checked all resistors around U7400 against another board and nothing seems bad. I took U7400 off a board with a RAM slot issue so I shouldn't have fitted a bad U7400.
Last edited:


I gave up checking around and took another U7400 from another board just on the off chance it was also bad. F'ing thing started straight up. No idea why the first swap was bad as it came of a nearly working board that just glitched every time you touched a ram stick of slot.

Anyway, thank you for your help. Please mark this one as solved.