[SOLVED]820-3662 - Blinking folder


This one does not detect internal SSD. It shows the blinking folder icon.

The SSD works in another machine (and no SSD works in this one)

The computer is fine when booted from external USB harddisk

Where do I start ?


I don't know exact history. The customer is kind of a weird guy who is really hard to have a conversation with. A man of few words.

It has been in an AASP where they just offered him to replace the MLB. I can not see any corrosion anywhere but when I looked on the board under the microscope I could see small brush marks as if someone tried to clean something off between the ram chips. I gave it a UC but still the same. I suspect it had a minor liquid damage at some point and I will see if I can get the customer to admit it.

the SSD controller gets a little hot (~50 C) when connected but is not recognized. When I take the SSD out and into another machine it is working fine and do not get as hot.


None of them missing. They all got value between 101-102 nF. And they all have continuity to SSD connector.


Yes. Several times. Same issue. Tried with several different SSDs (from different models and years) including PRAM reset every time I switched SSD. Just blinking folder. All the SSDs I tried works fine in another computer. And the SSD that came with this machine works fine in both another Retina and Air.


Never mind, i wanted to suggest smth but then realized you are talking about retina mbp which has a fonky ssd. Good luck solving this one.
Last edited:


without SSD connected

p53: 0.002
p52: 0.676
p51: 0.689
p50: 0.431
p49: OL
p48: 0.449
p47: 0.408
p46: 0.002
p45: 0.315
p44: 0.315
p43: 0.002
p42: 0.318
p41: 0.318
p40: 0.002
p39: 0.002
p38: 0.315
p37: 0.315
p36: 0.002
p35: 0.318
p34: 0.318
p33: 0.002
p32: 0.002
p31: 0.244
p30: 0.244
p29: 0.002

p59: 0.002
p60: 0.002
p61: 0.002
p62: 0.002
p63: 0.002
Last edited:


OK this is crazy. I measured some rails and found that PP3V3_S0 (pin 7 on J3700) had low resistance to GND. Only 10 ohm. How could I still have correct voltage on this rail (3.3V) ???

But it lead me to inject voltage on the rail and U3900 (camera BGA) got hot. I pulled it and the fucking machine is now booting. Now I obviously dont have camera support but who gives the shit.

I still dont understand why I had correct voltage readings on J3700. Shouldn't PP3V3_S0 have got pulled down ? Can you explain this ?

I did not measure voltage on PP3V3_S3RS0_CAMERA before i pulled U3900 but I assume it must had been low ?

What the fuck ????


3V bus can supply enough current into a 10 Ohm load. A rail will never be low because then there would be no "PGOOD" signal and the whole machine would be dead. A power rail is not some "no current" logic signal that can be anything between high and low.
I guess the dead U3900 was messing with the PCI_E bus.


Thanks for the explanation. It makes sense now. Mark solved and Merry Christmas :)

Oh. And just one more question. You mentioned in the first post that this not just happened by itself. Was it for sure some liquid (even though I did not find signs that could tell 100%) or can this chip fuck up by itself after all ?
Last edited: