[SOLVED]Milk Damaged 820-00165; did run, but no SSD detected, n̶o̶w̶ ̶d̶o̶e̶s̶ ̶m̶i̶x̶e̶d̶ ̶f̶a̶n̶ ̶s̶p̶i̶n̶

Paul Daniels

Super Moderator
[SOLVED]Milk Damaged 820-00165; did run, but no SSD detected, n̶o̶w̶ ̶d̶o̶e̶s̶ ̶m̶i̶x̶e̶d̶ ̶f̶a̶n̶ ̶s̶p̶i̶n̶

Milk damaged 820-00165, moderately extensive rework required, a lot of corroded out pads/parts replaced and some reconstruction required for L5001 area.

Was running after rework, would boot to external USB-SSD, but wouldn't detect internal SSD (crossed out circle even with known good SSD and system),

s̶o̶m̶e̶ ̶m̶o̶r̶e̶ ̶c̶h̶e̶c̶k̶i̶n̶g̶/̶r̶e̶w̶o̶r̶k̶i̶n̶g̶ ̶b̶u̶t̶ ̶n̶o̶w̶ ̶I̶ ̶g̶e̶t̶ ̶a̶ ̶m̶i̶x̶e̶d̶ ̶f̶a̶n̶s̶p̶i̶n̶ ̶a̶n̶d̶ ̶h̶o̶p̶i̶n̶g̶ ̶s̶o̶m̶e̶o̶n̶e̶ ̶c̶a̶n̶ ̶g̶i̶v̶e̶ ̶m̶e̶ ̶a̶ ̶p̶o̶i̶n̶t̶e̶r̶ ̶a̶s̶ ̶t̶o̶ ̶w̶h̶a̶t̶ ̶i̶t̶ ̶m̶i̶g̶h̶t̶ ̶i̶n̶d̶i̶c̶a̶t̶e̶;̶ ̶ ̶s̶h̶o̶r̶t̶ ̶f̶i̶r̶s̶t̶ ̶s̶p̶i̶n̶ ̶n̶o̶r̶m̶a̶l̶ ̶s̶e̶c̶o̶n̶d̶ ̶s̶p̶i̶n̶ ̶n̶o̶r̶m̶a̶l̶ ̶t̶h̶i̶r̶d̶ ̶s̶p̶i̶n̶ ̶q̶u̶a̶r̶t̶e̶r̶ ̶s̶p̶i̶n̶

The board is a mess overall, it's my own board, so don't put much effort in to this one, just looking for a rough indication of what that sort of fault that fan spin sequence might indicate.
Last edited:

Paul Daniels

Super Moderator
U8005:9 was corroded out, cleaned up, restored boot / fan behaviour, still no SSD detect. At least though it's a step forward.


Staff member
Start checking PP3V3_S0SW_SSD_FLT at J3700.
See if CLK100M_SSD oscillation is present.
Also check continuity from J3700 to C371x capacitors and U3710/11.

Paul Daniels

Super Moderator
Funny end to the story - turns out that the SSD was originally set up on a 3437, and it works fine on that, but... the moron n00b at work here, when tried in the 00165 it came up with the crossed out circle, which is why I was getting confused, because to my understanding the crossed out circle was more of a "I don't like the setup of the boot / partitions", than the blinking folder of "No device".

A boot in to Ubuntu with the SSD present revealed that it was perfectly fine ( physically ) which is why all the signals were "as expected".

Next time I'll wear my "Idiot at work" hat. Board is working great now, because it was always working great (after the original fix with the SMC issues).


New member
Hi Guys,
I have a similar issue the SSD is not detected when plugged in the motherboard and shows a question mark "?", other ssds are working fine.
So first I thought that the SSD was dead, but when I inserted it plugged it in the USB port this one is seen correctly, once in disk utility I saw that this ssd was formated in AFPS
So my second thought was: " this SSD was never in that board previously, and I need to update the SPI rom chip through High Sierra to be able to see AFPS ssds"
I took another ssd installed it in that mba installed Sierra then updated to High Sierra but still have that question mark.

Any suggestion?
I'm planning to migrate all the data of that "not detected" ssd in the other one then "format/analyse/repare"? it then clone it back from the good ssd

What do you think?