thread top ad

Collapse

Announcement

Collapse
No announcement yet.

820-3330-B with no video

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 820-3330-B with no video

    Howdy, I've got an 820-3330-B with no internal or external video. chimes with a solid sleep LED. all_gpu_good and all_sys_pwrgd present, gmux 3.3 1.2 and 1.8 rails all good, slp signals present.

    someone already ran jumper wire to bklt pins on lvds, so recall is out of the question

  • #2
    There are no recalls on 3330 boards anyway.
    If the sleep led stays on that could indicate SMC_LID is being held low, it needs to be high, check voltage there.

    Comment


    • #3
      smc_lid was the first thing I checked, it's present. strangely, if I close the lid, the LED will start breathing like it's in sleep mode, and when I open the lid, the LED turns off, but no video of course

      Comment


      • #4
        This was liquid?

        Comment


        • #5
          yes, prior person replaced LVDS and ran a jumper for bklt for some reason. thankfully the guy didn't clean anything off, so the area around the gpu was covered in dust and no liquid made it under the chip or even on that part of the board, only LVDS side. only darkened probe points are a few between the lvds connector and the fan connector

          Comment


          • #6
            Was the connector replace with the correct 2012 style connector?

            Comment


            • #7
              it's the one that is gold on the part that rests on the board, and silver on the top, unlike the earlier ones, so yeah, I think that's the right one.

              on a side note, where do you find these connectors? I can only find the 2009-2011 ones, this is the second 2012 15" board I've ever seen
              Last edited by rmd; 12-08-2016, 05:00 PM.

              Comment


              • #8
                I take them from donor boards. Did you check external video with the machine booted from a known good drive?

                Comment


                • #9
                  I'm getting no display on thunderbolt either, tried resettin gSMC and pram, all I get is chime but no video. all GPU rails look good and I'm basically lost at this point

                  Comment


                  • #10
                    Is OSX fully booting? With HDMI adapter OSX needs to be booted for external to work.

                    Comment


                    • #11
                      with a usb drive, it looks like it's booting off it since the LED will blink for a while, but even plugged in for five minutes, it doesn't give me video. in target disk mode, the drives won't pick up on another mac either.

                      [edit] hmm, after ten or so minutes, it shits itself off as well. neat
                      Last edited by rmd; 12-08-2016, 06:53 PM.

                      Comment


                      • #12
                        I really have no clues to give. The shutting down is not normal also. Are you checking external video without the LCD plugged in?

                        Comment


                        • #13
                          external with and without internal plugged in, can't get video at all. left it plugged in over night for shits and giggles and it was still on when I got to work this morning, so it's not shutting down at least. are the GPUs flakey in these like the 2011s?

                          Comment


                          • #14
                            These GPUs are not a known issue on these. You could enable remote login on the OS with a good machine and then boot this machine from that drive. You can then remotely login and see if the machine is booted and if the GPU is recognized.

                            Comment


                            • #15
                              I'm going to just throw in the towel with this one, thanks anyhow. I've got another one that isn't booting that I'll make a new thread for

                              Comment

                              thread bottom ad

                              Collapse
                              Working...
                              X